summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-07-04 06:59:52 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-07-04 06:59:52 +0000
commit98130501eb3331dd517e5091526b6cf4049ee6fe (patch)
tree59f3129bcc1338aa73324fce2cce5cd4fd484301 /dev-util
parentstable x86, bug 220479 (diff)
downloadgentoo-2-98130501eb3331dd517e5091526b6cf4049ee6fe.tar.gz
gentoo-2-98130501eb3331dd517e5091526b6cf4049ee6fe.tar.bz2
gentoo-2-98130501eb3331dd517e5091526b6cf4049ee6fe.zip
Make tests work, see bug #230646.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-tuxonice-r6 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mercurial/ChangeLog8
-rw-r--r--dev-util/mercurial/mercurial-1.0.1-r3.ebuild113
2 files changed, 120 insertions, 1 deletions
diff --git a/dev-util/mercurial/ChangeLog b/dev-util/mercurial/ChangeLog
index 6d5b0bbc6b3a..6b05ce59dac0 100644
--- a/dev-util/mercurial/ChangeLog
+++ b/dev-util/mercurial/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/mercurial
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/ChangeLog,v 1.73 2008/07/03 16:08:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/ChangeLog,v 1.74 2008/07/04 06:59:52 nelchael Exp $
+
+*mercurial-1.0.1-r3 (04 Jul 2008)
+
+ 04 Jul 2008; Krzysiek Pawlik <nelchael@gentoo.org>
+ +mercurial-1.0.1-r3.ebuild:
+ Make tests work, see bug #230646.
03 Jul 2008; Raúl Porcel <armin76@gentoo.org> mercurial-1.0.1-r2.ebuild:
alpha/ia64/sparc/x86 stable wrt #230193
diff --git a/dev-util/mercurial/mercurial-1.0.1-r3.ebuild b/dev-util/mercurial/mercurial-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..4c940cc7d328
--- /dev/null
+++ b/dev-util/mercurial/mercurial-1.0.1-r3.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-1.0.1-r3.ebuild,v 1.1 2008/07/04 06:59:52 nelchael Exp $
+
+inherit bash-completion distutils elisp-common flag-o-matic eutils
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://www.selenic.com/mercurial/"
+SRC_URI="http://www.selenic.com/mercurial/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bugzilla emacs gpg test zsh-completion"
+
+CDEPEND=">=dev-lang/python-2.3"
+RDEPEND="${CDEPEND}
+ bugzilla? ( dev-python/mysql-python )
+ gpg? ( app-crypt/gnupg )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${CDEPEND}
+ emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments )"
+
+PYTHON_MODNAME="${PN} hgext"
+SITEFILE="70${PN}-gentoo.el"
+
+src_unpack() {
+ distutils_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-87c704ac92d4-git-patch.patch"
+}
+
+src_compile() {
+ filter-flags -ftracer -ftree-vectorize
+
+ distutils_src_compile
+
+ if use emacs; then
+ cd "${S}"/contrib
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+
+ rm -rf contrib/{win32,macosx}
+}
+
+src_install() {
+ distutils_src_install
+
+ dobashcompletion contrib/bash_completion ${PN}
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+ fi
+
+ rm -f doc/*.?.txt
+ dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
+ cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
+
+ dobin contrib/hgk
+ dobin contrib/hg-relink
+ dobin contrib/hg-ssh
+
+ rm -f contrib/hgk contrib/hg-relink contrib/hg-ssh
+
+ rm -f contrib/bash_completion
+ cp -r contrib "${D}"/usr/share/doc/${PF}/
+ doman doc/*.?
+
+ cat > "${T}/80mercurial" <<-EOF
+HG=/usr/bin/hg
+EOF
+ doenvd "${T}/80mercurial"
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+}
+
+src_test() {
+ cd "${S}/tests/"
+ rm -f *svn* # Subversion tests fail with 1.5
+ rm -f test-convert-baz* # GNU Arch baz
+ rm -f test-convert-cvs* # CVS
+ rm -f test-convert-darcs* # Darcs
+ rm -f test-convert-git* # git
+ rm -f test-convert-mtn* # monotone
+ rm -f test-convert-tla* # GNU Arch tla
+ einfo "Running Mercurial tests ..."
+ python run-tests.py || die "test failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-util/cvs"
+ elog " dev-util/darcs"
+ elog " dev-util/git"
+ elog " dev-util/monotone"
+ elog " dev-util/subversion"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}