summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-10-02 14:52:28 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-10-02 14:52:28 +0000
commit9c35512ac49b725f0c4d40ecbf2f9f5ddf7564b7 (patch)
tree4fdc058311d453ab925287b812b2c2936469bb0b /dev-util
parentStable on alpha, bug #307759 (diff)
downloadgentoo-2-9c35512ac49b725f0c4d40ecbf2f9f5ddf7564b7.tar.gz
gentoo-2-9c35512ac49b725f0c4d40ecbf2f9f5ddf7564b7.tar.bz2
gentoo-2-9c35512ac49b725f0c4d40ecbf2f9f5ddf7564b7.zip
Make package respecting LDFLAGS (bug #338143). Tested on amd64 and keyworded.
(Portage version: 2.1.9.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/as11/ChangeLog8
-rw-r--r--dev-util/as11/as11-1.0.ebuild12
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-util/as11/ChangeLog b/dev-util/as11/ChangeLog
index 67ed3de0e26f..61964dcd0045 100644
--- a/dev-util/as11/ChangeLog
+++ b/dev-util/as11/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/as11
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/as11/ChangeLog,v 1.8 2009/09/23 17:40:06 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/as11/ChangeLog,v 1.9 2010/10/02 14:52:28 tomjbe Exp $
+
+ 02 Oct 2010; Thomas Beierlein <tomjbe@gentoo.org> as11-1.0.ebuild:
+ Make package respecting LDFLAGS (bug #338143). Tested on amd64 and
+ keyworded.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> as11-1.0.ebuild:
Remove virtual/libc
diff --git a/dev-util/as11/as11-1.0.ebuild b/dev-util/as11/as11-1.0.ebuild
index 6e58c1b8377f..15d46b6a2dbe 100644
--- a/dev-util/as11/as11-1.0.ebuild
+++ b/dev-util/as11/as11-1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/as11/as11-1.0.ebuild,v 1.8 2009/09/23 17:40:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/as11/as11-1.0.ebuild,v 1.9 2010/10/02 14:52:28 tomjbe Exp $
+
+EAPI="2"
inherit toolchain-funcs
@@ -10,7 +12,7 @@ SRC_URI="http://www.ai.mit.edu/people/rsargent/source/${PN}_src.tar.gz"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
S=${WORKDIR}/${PN}
@@ -18,6 +20,10 @@ S=${WORKDIR}/${PN}
DEPEND=""
RDEPEND=""
+src_prepare() {
+ sed -i -e "s/ -o/\$(LDFLAGS) -o/g" Makefile || die
+}
+
src_compile() {
emake CC="$(tc-getCC)" || die "Compile failed"
}