summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-06-09 20:38:30 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-06-09 20:38:30 +0000
commita634a90119543177201252afe26bc124d93d2c06 (patch)
tree21cb91a84e3b0c945188f6a4dbd0f06e773cbfaf /dev-util
parentFixed unaligned access on platforms not supporting one (http://libtorrent.rak... (diff)
downloadgentoo-2-a634a90119543177201252afe26bc124d93d2c06.tar.gz
gentoo-2-a634a90119543177201252afe26bc124d93d2c06.tar.bz2
gentoo-2-a634a90119543177201252afe26bc124d93d2c06.zip
Fixed to build against linux-3.x, bug #370857
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.1-linux-3.patch11
-rw-r--r--dev-util/valgrind/valgrind-3.6.1-r1.ebuild100
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 70e4a85f6df9..3c2cdf9a1679 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.123 2011/05/22 23:56:30 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.124 2011/06/09 20:38:30 blueness Exp $
+
+*valgrind-3.6.1-r1 (09 Jun 2011)
+
+ 09 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.6.1-r1.ebuild, +files/valgrind-3.6.1-linux-3.patch:
+ Fixed to build against linux-3.x, bug #370857
22 May 2011; Joseph Jezak <josejx@gentoo.org> valgrind-3.6.1.ebuild:
Marked ppc/ppc64 stable for bug #360781.
diff --git a/dev-util/valgrind/files/valgrind-3.6.1-linux-3.patch b/dev-util/valgrind/files/valgrind-3.6.1-linux-3.patch
new file mode 100644
index 000000000000..143cfb9c6745
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.1-linux-3.patch
@@ -0,0 +1,11 @@
+--- configure.in 2011-06-09 16:33:14.000000000 -0400
++++ configure.in.orig 2011-06-09 16:33:08.000000000 -0400
+@@ -220,7 +220,7 @@
+ kernel=`uname -r`
+
+ case "${kernel}" in
+- 2.6.*)
++ 2.6.*|3.*)
+ AC_MSG_RESULT([2.6 family (${kernel})])
+ AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x])
+ ;;
diff --git a/dev-util/valgrind/valgrind-3.6.1-r1.ebuild b/dev-util/valgrind/valgrind-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..bc39f12099de
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.6.1-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.6.1-r1.ebuild,v 1.1 2011/06/09 20:38:30 blueness Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi qt4"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Respect CFLAGS, LDFLAGS
+ sed -i -e '/^CPPFLAGS =/d' -e '/^CFLAGS =/d' -e '/^LDFLAGS =/d' \
+ mpi/Makefile.am || die
+
+ # Changing Makefile.all.am to disable SSP
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' \
+ Makefile.all.am || die
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" \
+ docs/Makefile.am || die
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.6.0-non-exec-stack.patch
+
+ # Fix up some suppressions that were not general enough for glibc versions
+ # with more than just a major and minor number.
+ epatch "${FILESDIR}"/${PN}-3.4.1-glibc-2.10.1.patch
+
+ # Remove automagic dependency on qt4
+ epatch "${FILESDIR}"/${PN}-3.6.1-user-enable-qt4.patch
+
+ # Allow valgrind to build against linux-3, bug #370857
+ epatch "${FILESDIR}"/${PN}-3.6.1-linux-3.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ if ! use qt4; then
+ myconf="${myconf} --disable-qtcore"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${D}"/usr/$(get_libdir)/valgrind/*-*-linux
+}
+
+pkg_postinst() {
+ if use ppc || use ppc64 || use amd64 ; then
+ ewarn "Valgrind will not work on ppc, ppc64 or amd64 if glibc does not have"
+ ewarn "debug symbols (see https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "and http://bugs.gentoo.org/show_bug.cgi?id=274771)."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf and"
+ ewarn "remerge glibc."
+ fi
+}