summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-10-30 10:41:26 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-10-30 10:41:26 +0000
commitbdbd357292e571d4b9fbd14e80e092c6a4f92599 (patch)
tree0b9451bed8469d3df1e4b56e69e49982dacadc30 /dev-util
parentAdded ~sparc-fbsd keyword. (diff)
downloadgentoo-2-bdbd357292e571d4b9fbd14e80e092c6a4f92599.tar.gz
gentoo-2-bdbd357292e571d4b9fbd14e80e092c6a4f92599.tar.bz2
gentoo-2-bdbd357292e571d4b9fbd14e80e092c6a4f92599.zip
New upstream version, remove old one.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-1.4.3.39
-rw-r--r--dev-util/git/git-1.4.3.3.ebuild151
3 files changed, 167 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 59e489c3fbbd..ecd51856ef23 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.139 2006/10/28 11:04:01 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.140 2006/10/30 10:41:26 ferdy Exp $
+
+*git-1.4.3.3 (30 Oct 2006)
+
+ 30 Oct 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.3.2.ebuild,
+ +git-1.4.3.3.ebuild:
+ New upstream version, remove old one.
28 Oct 2006; Christian Faulhammer <opfer@gentoo.org> git-1.4.2.4.ebuild:
x86 stable wrt bug #151669
diff --git a/dev-util/git/files/digest-git-1.4.3.3 b/dev-util/git/files/digest-git-1.4.3.3
new file mode 100644
index 000000000000..6c8efc5e4cd5
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.3.3
@@ -0,0 +1,9 @@
+MD5 a40394f8072950ae45cf95746036803d git-1.4.3.3.tar.bz2 858389
+RMD160 3d42661991b805c7e179551cf88b513440bfa164 git-1.4.3.3.tar.bz2 858389
+SHA256 550e8b79e5a4e3c57d4b6cdccc307baab4e4d41ffb23db382a0e3be24e46d42d git-1.4.3.3.tar.bz2 858389
+MD5 7d045008058a161fb44f8babd16c6ced git-htmldocs-1.4.3.3.tar.bz2 302246
+RMD160 d491a7db58b6cf37ab71c9b151089d0229d6e113 git-htmldocs-1.4.3.3.tar.bz2 302246
+SHA256 87d5f62fe3d0a62168f8ec1dd7318fc029dafe185e43fafda730cdf2a8df5332 git-htmldocs-1.4.3.3.tar.bz2 302246
+MD5 95e28a5cc55113e01c02d9e39f8db981 git-manpages-1.4.3.3.tar.bz2 96856
+RMD160 81b4aabfaaf3a90a3eace11f5de991136884636b git-manpages-1.4.3.3.tar.bz2 96856
+SHA256 3c0617129eb3044ac6fde66b4554e5c0c125c7389b35f70749a864d758cdc248 git-manpages-1.4.3.3.tar.bz2 96856
diff --git a/dev-util/git/git-1.4.3.3.ebuild b/dev-util/git/git-1.4.3.3.ebuild
new file mode 100644
index 000000000000..fb73dc5cfc31
--- /dev/null
+++ b/dev-util/git/git-1.4.3.3.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.3.3.ebuild,v 1.1 2006/10/30 10:41:26 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module bash-completion
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ einfo " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo "These additional scripts need some dependencies:"
+ einfo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn "dev-util/subversion(USE=perl)" "dev-perl/libwww-perl"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dep-perl/DBD-SQLite"
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}