summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-07-31 02:02:38 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-07-31 02:02:38 +0000
commitd2edae9b3557fd54f83ecafd5620dd6146ad8d4b (patch)
treed82eede8b222e787b8a26dbad69c83943d2b9a58 /dev-util
parentPunt older 2.5.x, version bump 2.5.3 and 2.6.1 (diff)
downloadgentoo-2-d2edae9b3557fd54f83ecafd5620dd6146ad8d4b.tar.gz
gentoo-2-d2edae9b3557fd54f83ecafd5620dd6146ad8d4b.tar.bz2
gentoo-2-d2edae9b3557fd54f83ecafd5620dd6146ad8d4b.zip
Version bump
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconf/ChangeLog7
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index e87ac02e091c..2ba75a0cae6d 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.37 2012/07/30 13:43:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.38 2012/07/31 02:02:38 jdhore Exp $
+
+*pkgconf-0.8.5 (31 Jul 2012)
+
+ 31 Jul 2012; Jeff Horelick <jdhore@gentoo.org> +pkgconf-0.8.5.ebuild:
+ Version bump
30 Jul 2012; Anthony G. Basile <blueness@gentoo.org> pkgconf-0.8.4.ebuild:
Stable ppc ppc64, bug #427680
diff --git a/dev-util/pkgconf/pkgconf-0.8.5.ebuild b/dev-util/pkgconf/pkgconf-0.8.5.ebuild
new file mode 100644
index 000000000000..44e74128391d
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.8.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.5.ebuild,v 1.1 2012/07/31 02:02:38 jdhore Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/nenolod/pkgconf.git"
+ inherit autotools git-2
+else
+ #inherit autotools vcs-snapshot
+ inherit eutils
+ #SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
+ SRC_URI="http://nenolod.net/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/nenolod/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+src_prepare() {
+ [[ -e configure ]] || AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable strict)
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}