summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-06-03 19:55:49 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-06-03 19:55:49 +0000
commitea8c0336df61c5290f468f137f445e5c79c1e8a4 (patch)
tree95878f37211b08f5e36e014db2d607764dbde869 /dev-util
parentRemove old difffilter-0.2. (diff)
downloadgentoo-2-ea8c0336df61c5290f468f137f445e5c79c1e8a4.tar.gz
gentoo-2-ea8c0336df61c5290f468f137f445e5c79c1e8a4.tar.bz2
gentoo-2-ea8c0336df61c5290f468f137f445e5c79c1e8a4.zip
Bump to difffilter-0.3.1, which now depends on libstrl.
(Portage version: 2.2.0_alpha34-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/difffilter/ChangeLog8
-rw-r--r--dev-util/difffilter/difffilter-0.3.1.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-util/difffilter/ChangeLog b/dev-util/difffilter/ChangeLog
index be9a6a1379cf..971e6efe2c3a 100644
--- a/dev-util/difffilter/ChangeLog
+++ b/dev-util/difffilter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/difffilter
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/difffilter/ChangeLog,v 1.8 2011/06/03 19:49:20 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/difffilter/ChangeLog,v 1.9 2011/06/03 19:55:49 binki Exp $
+
+*difffilter-0.3.1 (03 Jun 2011)
+
+ 03 Jun 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +difffilter-0.3.1.ebuild:
+ Bump to difffilter-0.3.1, which now depends on libstrl.
03 Jun 2011; Nathan Phillip Brink <binki@gentoo.org>
-difffilter-0.2.ebuild:
diff --git a/dev-util/difffilter/difffilter-0.3.1.ebuild b/dev-util/difffilter/difffilter-0.3.1.ebuild
new file mode 100644
index 000000000000..4666286908bf
--- /dev/null
+++ b/dev-util/difffilter/difffilter-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/difffilter/difffilter-0.3.1.ebuild,v 1.1 2011/06/03 19:55:49 binki Exp $
+
+EAPI=3
+
+inherit autotools-utils
+
+DESCRIPTION="Filter files out of unified diffs using POSIX extended regular expressions"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/difffilter/"
+SRC_URI="ftp://ohnopub.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/liblist-2.3.1
+ dev-libs/libstrl
+ dev-libs/tre"
+DEPEND="doc? ( app-text/txt2man )
+ ${RDEPEND}"
+
+src_configure() {
+ local myconfargs=(
+ $(use_enable doc)
+ )
+
+ autotools-utils_src_configure
+}