summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-02-26 23:29:17 +0000
committerMarius Mauch <genone@gentoo.org>2004-02-26 23:29:17 +0000
commitf7b123ee8cc0948094bcf36530add99510de1a5c (patch)
tree393166da3315a1c942accd293703a400a717777a /dev-util
parentPruning obsolete ebuilds and patch files (Manifest recommit) (diff)
downloadgentoo-2-f7b123ee8cc0948094bcf36530add99510de1a5c.tar.gz
gentoo-2-f7b123ee8cc0948094bcf36530add99510de1a5c.tar.bz2
gentoo-2-f7b123ee8cc0948094bcf36530add99510de1a5c.zip
version bump, adding support for more USE flags, removing -Os from default CFLAGS
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gambas/ChangeLog9
-rw-r--r--dev-util/gambas/files/Makefile.am-0.9035
-rw-r--r--dev-util/gambas/files/digest-gambas-0.901
-rw-r--r--dev-util/gambas/files/non-symlink-0.90.patch64
-rw-r--r--dev-util/gambas/gambas-0.90.ebuild76
5 files changed, 184 insertions, 1 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index c530a467ece6..646a37bb6087 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.4 2004/02/10 22:33:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.5 2004/02/26 23:29:17 genone Exp $
+
+*gambas-0.90 (27 Feb 2004)
+
+ 27 Feb 2004; Marius Mauch <genone@gentoo.org> gambas-0.90.ebuild,
+ files/Makefile.am-0.90, files/non-symlink-0.90.patch:
+ version bump, adding support for more USE flags, removing -Os from default
+ CFLAGS
*gambas-0.82 (05 Feb 2004)
diff --git a/dev-util/gambas/files/Makefile.am-0.90 b/dev-util/gambas/files/Makefile.am-0.90
new file mode 100644
index 000000000000..d1a1b53d2097
--- /dev/null
+++ b/dev-util/gambas/files/Makefile.am-0.90
@@ -0,0 +1,35 @@
+SUBDIRS = libltdl src
+EXTRA_DIST = TODO reconf app examples help README.REDHAT
+##AUTOMAKE_OPTIONS = dist-bzip2
+
+install-exec-local:
+ @echo
+ @echo "Installing the development environment..."
+ @(cd $(srcdir)/app; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
+ gbc -ag; gba; rm -rf .gambas; $(INSTALL) $$p $(bindir); done)
+
+ @echo
+ @echo "Creating the library info files..."
+ @$(INSTALL) -d $(libdir)/info
+ @$(bindir)/gbi -a
+ @rm -f $(libdir)/lib.gb.la
+ @rm -f $(libdir)/lib.gb.so*
+
+ @echo
+ @echo "Installing the gambas help files..."
+ @$(INSTALL) -d $(datadir)/help
+ @rm -rf $(datadir)/help
+ @cp -R $(srcdir)/help $(datadir)
+
+ @echo
+ @echo "Installing the gambas examples..."
+ @rm -rf $(datadir)/examples
+ @$(INSTALL) -d $(datadir)/examples
+ @cp -R $(srcdir)/examples $(datadir)
+ @(cd $(datadir)/examples; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
+ gbc -ag; gba; done)
+
+dist-hook:
+ @(cd $(distdir)/app; for p in *; do rm -rf $$p/.gambas $$p/.xvpics $$p/*/.xvpics $$p/*/*/.xvpics $$p/*~ $$p/.*.out $$p/*.out $$p/.lang/*.pot $$p/$$p; done)
+ @(cd $(distdir)/examples; for p in *; do rm -rf $$p/.gambas $$p/.xvpics $$p/*/.xvpics $$p/*/*/.xvpics $$p/*~ $$p/.*.out $$p/*.out $$p/.lang/*.pot $$p/$$p; done)
+
diff --git a/dev-util/gambas/files/digest-gambas-0.90 b/dev-util/gambas/files/digest-gambas-0.90
new file mode 100644
index 000000000000..4471e2fc406c
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.90
@@ -0,0 +1 @@
+MD5 1f3211e2c97a354205123a71441e6ced gambas-0.90.tar.bz2 2646331
diff --git a/dev-util/gambas/files/non-symlink-0.90.patch b/dev-util/gambas/files/non-symlink-0.90.patch
new file mode 100644
index 000000000000..d36d2a5607c9
--- /dev/null
+++ b/dev-util/gambas/files/non-symlink-0.90.patch
@@ -0,0 +1,64 @@
+--- src/comp/gbi.c.org 2003-10-27 21:51:41.000000000 +0100
++++ src/comp/gbi.c 2003-11-17 23:41:29.000000000 +0100
+@@ -54,6 +54,34 @@
+ #include "str.h"
+ #include "gambas.h"
+
++/* needed to install in a different location than /usr */
++char *which(const char *app)
++{
++ char *path = NULL;
++ char *p = NULL;
++ char *rValue = NULL;
++
++ path = getenv("PATH");
++ if (!path) {
++ path = "/usr/bin/";
++ }
++ p = strtok(strdup(path), ":");
++ while (p) {
++ rValue = (char *)calloc(sizeof(char), strlen(p)+strlen(app)+2);
++ strcat(rValue, p);
++ rValue[strlen(p)] = '/';
++ strcat(rValue, app);
++ rValue[strlen(p)+1+strlen(app)] = '\0';
++ if (access(rValue, X_OK) == 0) {
++ return rValue;
++ }
++ p = strtok(NULL, ":");
++ free(rValue);
++ rValue = NULL;
++ }
++ return NULL;
++}
++
+
+ PRIVATE char _lib_path[MAX_PATH + 1];
+ PRIVATE FILE *out;
+@@ -102,7 +129,7 @@
+
+ /* chemin d'installation de Gambas */
+
+- path = FILE_readlink(GAMBAS_LINK_PATH);
++ path = which("gbx");
+ if (!path)
+ {
+ path = GAMBAS_LINK_PATH;
+@@ -422,7 +450,7 @@
+ if (strcmp(name, "gb") == 0)
+ {
+ sprintf(path, LIB_PATTERN, _lib_path, name);
+- dlib = dlopen("/usr/bin/gbx", RTLD_NOW);
++ dlib = dlopen(which("gbx"), RTLD_NOW);
+ if (!dlib)
+ error2("Cannot open component:", dlerror());
+
+@@ -472,7 +500,7 @@
+ sprintf(buf, "LD_PRELOAD=%s", lib);
+ putenv(buf);
+ putenv("GAMBAS_PRELOAD=1");
+- execv("/usr/bin/gbi", argv);
++ execvp("gbi", argv);
+ #endif
+ }
+
diff --git a/dev-util/gambas/gambas-0.90.ebuild b/dev-util/gambas/gambas-0.90.ebuild
new file mode 100644
index 000000000000..0b29c250158d
--- /dev/null
+++ b/dev-util/gambas/gambas-0.90.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.90.ebuild,v 1.1 2004/02/26 23:29:17 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="kde postgres mysql sdl doc qt curl debug"
+DEPEND=">=sys-devel/automake-1.7.5
+ >=x11-base/xfree-4.3.0
+ >=x11-libs/qt-3.2
+ kde? ( >=kde-base/kdelibs-3.2 )
+ sdl? ( media-libs/libsdl )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-ftp/curl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:^ *CFLAGS=.*-Os.*::' 's:^ *CXXFLAGS=.*-Os.*::' configure
+ # replace braindead Makefile
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-${PV}" ./Makefile.am
+ automake
+ # patch against hardcoded paths
+ epatch ${FILESDIR}/non-symlink-${PV}.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} `use_enable kde`"
+ myconf="${myconf} `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable curl`"
+ myconf="${myconf} `use_enable qt`"
+ if use debug; then
+ myconf="${myconf} --disable-optimization --enable-debug"
+ else
+ myconf="${myconf} --enable-optimization --disable-debug"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ einstall || die
+
+ cd ${S}
+ dodoc README INSTALL NEWS AUTHORS ChangeLog COPYING TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
+ einfo "Compiling examples ..."
+ cd ${D}/usr/share/doc/${PF}/examples
+ for p in *; do
+ cd $p
+ gbc -ag
+ gba
+ cd ..
+ done
+ fi
+ rm -rf ${D}/usr/share/help ${D}/usr/share/examples
+}