summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-24 21:19:51 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-24 21:19:51 +0000
commit6006a760f88df72b1914f9f1cbc854e15e1db1c0 (patch)
tree0dbd7cb2a970826f99ce4a8be67eff2684c78812 /dev-vcs/git-cola
parentDelete unused local variable. (diff)
downloadgentoo-2-6006a760f88df72b1914f9f1cbc854e15e1db1c0.tar.gz
gentoo-2-6006a760f88df72b1914f9f1cbc854e15e1db1c0.tar.bz2
gentoo-2-6006a760f88df72b1914f9f1cbc854e15e1db1c0.zip
Inform the user to install a ssh-askpass app, don't install the tk-based askpass, set the default askpass to be x11-ssh-askpass (bug #415297).
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/ChangeLog10
-rw-r--r--dev-vcs/git-cola/files/1.7.7-system-ssh-askpass.patch32
-rw-r--r--dev-vcs/git-cola/git-cola-1.7.7-r1.ebuild96
-rw-r--r--dev-vcs/git-cola/metadata.xml3
4 files changed, 140 insertions, 1 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index aa9afc2ff091..fe0b4542b8f6 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.2 2012/05/11 09:42:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.3 2012/05/24 21:19:51 dev-zero Exp $
+
+*git-cola-1.7.7-r1 (24 May 2012)
+
+ 24 May 2012; Tiziano Müller <dev-zero@gentoo.org>
+ +files/1.7.7-system-ssh-askpass.patch, +git-cola-1.7.7-r1.ebuild,
+ metadata.xml:
+ Inform the user to install a ssh-askpass app, don't install the tk-based
+ askpass, set the default askpass to be x11-ssh-askpass (bug #415297).
*git-cola-1.7.7 (11 May 2012)
diff --git a/dev-vcs/git-cola/files/1.7.7-system-ssh-askpass.patch b/dev-vcs/git-cola/files/1.7.7-system-ssh-askpass.patch
new file mode 100644
index 000000000000..665070d7acd1
--- /dev/null
+++ b/dev-vcs/git-cola/files/1.7.7-system-ssh-askpass.patch
@@ -0,0 +1,32 @@
+diff --git a/cola/app.py b/cola/app.py
+index a689fdb..9618c3e 100644
+--- a/cola/app.py
++++ b/cola/app.py
+@@ -52,10 +52,10 @@ def setup_environment():
+ # Provide an SSH_ASKPASS fallback
+ if sys.platform == 'darwin':
+ os.environ.setdefault('SSH_ASKPASS',
+- resources.share('bin', 'ssh-askpass-darwin'))
++ resources.prefix('bin', 'ssh-askpass-darwin'))
+ else:
+ os.environ.setdefault('SSH_ASKPASS',
+- resources.share('bin', 'ssh-askpass'))
++ resources.prefix('bin', 'x11-ssh-askpass'))
+
+ # Setup the path so that git finds us when we run 'git cola'
+ path_entries = os.environ.get('PATH').split(os.pathsep)
+diff --git a/setup.py b/setup.py
+index d639eda..90d5fd0 100755
+--- a/setup.py
++++ b/setup.py
+@@ -101,10 +101,6 @@ def cola_data_files():
+ data.extend([_app_path(localedir, 'git-cola.mo')
+ for localedir in glob('share/locale/*/LC_MESSAGES')])
+
+- if sys.platform == 'darwin':
+- data.append(_app_path('share/git-cola/bin', 'ssh-askpass-darwin'))
+- else:
+- data.append(_app_path('share/git-cola/bin', 'ssh-askpass'))
+ return data
+
+
diff --git a/dev-vcs/git-cola/git-cola-1.7.7-r1.ebuild b/dev-vcs/git-cola/git-cola-1.7.7-r1.ebuild
new file mode 100644
index 000000000000..54a4751f773e
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-1.7.7-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.7.7-r1.ebuild,v 1.1 2012/05/24 21:19:51 dev-zero Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="http://git-cola.github.com/"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jsonpickle
+ dev-python/pyinotify
+ dev-python/PyQt4
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ dev-python/sphinx
+ app-text/xmlto )
+ sys-devel/gettext
+ test? ( dev-python/nose )"
+
+# tests currently broken due to unfinished translation framework
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -i \
+ -e '/doc/d' \
+ setup.py || die "sed failed"
+
+ sed -i \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ cola/resources.py || die "sed failed"
+
+ epatch \
+ "${FILESDIR}"/1.3.8-disable-tests.patch \
+ "${FILESDIR}"/1.7.7-system-ssh-askpass.patch
+
+ python_convert_shebangs 2 bin/git-cola bin/git-dag
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd share/doc/git-cola/
+ emake all
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc share/doc/git-cola/*.txt
+
+ if use doc ; then
+ dohtml -r _build/html/*
+ doman *.1
+ else
+ dohtml "${FILESDIR}/index.html"
+ fi
+}
+
+src_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
+ --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
+ || die "running nosetests failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/git-cola/lib/cola
+
+ elog "Please make sure you have either a SSH key management installed and activated or"
+ elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
+ elog "Otherwise git-cola may hang when pushing/pulling from remote git repositories via SSH. "
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/git-cola/lib/cola
+}
diff --git a/dev-vcs/git-cola/metadata.xml b/dev-vcs/git-cola/metadata.xml
index 8e67c9e7a8af..a0a3b9afe563 100644
--- a/dev-vcs/git-cola/metadata.xml
+++ b/dev-vcs/git-cola/metadata.xml
@@ -9,4 +9,7 @@
<email>jlec@gentoo.org</email>
<name>Justin Lecher</name>
</maintainer>
+ <use>
+ <flag name='ssh'>Make sure at least one dependency required for asking the user for a password is installed.</flag>
+ </use>
</pkgmetadata>