summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-15 12:00:19 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-15 12:00:19 +0000
commitebf1b974d57669c44625157660ebcb3d031ee026 (patch)
tree0255f2b293a33e9eb1a676067f93d63ee92d3551 /dev-vcs/git-cola
parentStable for x86, wrt bug #497246 (diff)
downloadgentoo-2-ebf1b974d57669c44625157660ebcb3d031ee026.tar.gz
gentoo-2-ebf1b974d57669c44625157660ebcb3d031ee026.tar.bz2
gentoo-2-ebf1b974d57669c44625157660ebcb3d031ee026.zip
dev-vcs/git-cola: Version Bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/ChangeLog10
-rw-r--r--dev-vcs/git-cola/files/git-cola-1.9.3-disable-tests.patch21
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.3.ebuild94
3 files changed, 123 insertions, 2 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index 053345a6bd53..20366110f08c 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-cola
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.17 2013/11/07 16:56:56 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.18 2014/01/15 12:00:19 jlec Exp $
+
+*git-cola-1.9.3 (15 Jan 2014)
+
+ 15 Jan 2014; Justin Lecher <jlec@gentoo.org> +git-cola-1.9.3.ebuild,
+ +files/git-cola-1.9.3-disable-tests.patch:
+ Version Bump
*git-cola-1.9.1 (07 Nov 2013)
diff --git a/dev-vcs/git-cola/files/git-cola-1.9.3-disable-tests.patch b/dev-vcs/git-cola/files/git-cola-1.9.3-disable-tests.patch
new file mode 100644
index 000000000000..79f1ec2ff8bc
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-1.9.3-disable-tests.patch
@@ -0,0 +1,21 @@
+diff -Naur cola-1.3.7.21.orig/test/git_test.py cola-1.3.7.21/test/git_test.py
+--- cola-1.3.7.21.orig/test/git_test.py 2009-04-30 13:56:22.352319047 +0200
++++ cola-1.3.7.21/test/git_test.py 2009-04-30 13:56:53.123149963 +0200
+@@ -24,17 +24,6 @@
+ version = self.git.version()[STDOUT]
+ self.failUnless(version.startswith('git version'))
+
+- def test_tag(self):
+- """Test running 'git tag'"""
+- tags = self.git.tag()[STDOUT].splitlines()
+- self.failUnless( 'v1.0.0' in tags )
+-
+- def test_show(self):
+- """Test running 'git show'"""
+- sha = '1b9742bda5d26a4f250fa64657f66ed20624a084'
+- contents = self.git.show(sha)[STDOUT].splitlines()
+- self.failUnless(contents[0] == '/build')
+-
+ def test_stdout(self):
+ """Test overflowing the stdout buffer"""
+ # Write to stdout only
diff --git a/dev-vcs/git-cola/git-cola-1.9.3.ebuild b/dev-vcs/git-cola/git-cola-1.9.3.ebuild
new file mode 100644
index 000000000000..fca042ad2977
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-1.9.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.3.ebuild,v 1.1 2014/01/15 12:00:19 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="http://git-cola.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jsonpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ sys-devel/gettext
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-tests.patch
+ "${FILESDIR}"/${PN}-1.9.1-system-ssh-askpass.patch
+ )
+
+python_prepare_all() {
+ rm share/git-cola/bin/*askpass* || die
+
+ # unfinished translate framework
+ rm test/i18n_test.py || die
+
+ # don't install docs into wrong location
+ sed -i \
+ -e '/doc/d' \
+ setup.py || die "sed failed"
+
+ sed -i \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ cola/resources.py || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ cd share/doc/${PN}/
+ if use doc ; then
+ emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -i Makefile || die
+ fi
+}
+
+python_install_all() {
+ cd share/doc/${PN}/ || die
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ if use doc ; then
+ HTML_DOCS=( share/doc/${PN}/_build/html/. )
+ else
+ HTML_DOCS=( "${FILESDIR}"/index.html )
+ fi
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
+ --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
+ || die "running nosetests failed"
+}
+
+pkg_postinst() {
+ elog "Please make sure you have either a SSH key management installed and activated or"
+ elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
+ elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
+}