summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-27 17:30:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-27 17:30:47 +0000
commit9f1fb72a6bb0c2d7c7e6f72e7803fd5626c4319e (patch)
treec1a506d05d524d8df0aca21842883fa17fb54e5e /dev-vcs/monotone
parentMasked sci-calculators/orpie for removal (diff)
downloadgentoo-2-9f1fb72a6bb0c2d7c7e6f72e7803fd5626c4319e.tar.gz
gentoo-2-9f1fb72a6bb0c2d7c7e6f72e7803fd5626c4319e.tar.bz2
gentoo-2-9f1fb72a6bb0c2d7c7e6f72e7803fd5626c4319e.zip
Fix building with GCC 4.5 wrt #317509 by Philipp.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/monotone')
-rw-r--r--dev-vcs/monotone/ChangeLog6
-rw-r--r--dev-vcs/monotone/files/monotone-0.45-gcc45.patch12
-rw-r--r--dev-vcs/monotone/monotone-0.45.ebuild6
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-vcs/monotone/ChangeLog b/dev-vcs/monotone/ChangeLog
index 121fd7d46b2e..42cc09d4d99f 100644
--- a/dev-vcs/monotone/ChangeLog
+++ b/dev-vcs/monotone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/monotone
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.1 2010/03/05 16:49:35 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/ChangeLog,v 1.2 2010/04/27 17:30:46 ssuominen Exp $
+
+ 27 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> monotone-0.45.ebuild,
+ +files/monotone-0.45-gcc45.patch:
+ Fix building with GCC 4.5 wrt #317509 by Philipp.
05 Mar 2010; Sebastian Pipping <sping@gentoo.org>
+files/50monotone-gentoo.el, +files/monotone-0.36.initd,
diff --git a/dev-vcs/monotone/files/monotone-0.45-gcc45.patch b/dev-vcs/monotone/files/monotone-0.45-gcc45.patch
new file mode 100644
index 000000000000..d343dcd4a626
--- /dev/null
+++ b/dev-vcs/monotone/files/monotone-0.45-gcc45.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/show_bug.cgi?id=317509
+
+--- selectors.cc
++++ selectors.cc
+@@ -18,6 +18,7 @@
+ #include "cmd.hh"
+ #include "work.hh"
+ #include "transforms.hh"
++#include "roster.hh"
+
+ #include <algorithm>
+ #include <boost/tokenizer.hpp>
diff --git a/dev-vcs/monotone/monotone-0.45.ebuild b/dev-vcs/monotone/monotone-0.45.ebuild
index db7c75371d64..5875806bec5a 100644
--- a/dev-vcs/monotone/monotone-0.45.ebuild
+++ b/dev-vcs/monotone/monotone-0.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/monotone-0.45.ebuild,v 1.1 2010/03/05 16:49:35 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/monotone/monotone-0.45.ebuild,v 1.2 2010/04/27 17:30:46 ssuominen Exp $
EAPI=2
inherit bash-completion elisp-common eutils
@@ -34,6 +34,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
src_configure() {
econf \
$(use_enable nls) \