summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-09-19 20:43:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-09-19 20:43:14 +0000
commit7770f40d0ed29a9d25ebf9b0c523cb2b9f4e1179 (patch)
tree23573004697a510663413ae09595b3cf4d459408 /dev-vcs/tig
parentia64/s390/sh/sparc stable wrt #327777 (diff)
downloadgentoo-2-7770f40d0ed29a9d25ebf9b0c523cb2b9f4e1179.tar.gz
gentoo-2-7770f40d0ed29a9d25ebf9b0c523cb2b9f4e1179.tar.bz2
gentoo-2-7770f40d0ed29a9d25ebf9b0c523cb2b9f4e1179.zip
Version bump.
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-0.16.1.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index 1794b92362fb..540db855040d 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.2 2010/06/15 17:35:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.3 2010/09/19 20:43:14 robbat2 Exp $
+
+*tig-0.16.1 (19 Sep 2010)
+
+ 19 Sep 2010; Robin H. Johnson <robbat2@gentoo.org> +tig-0.16.1.ebuild:
+ Version bump.
*tig-0.16 (15 Jun 2010)
diff --git a/dev-vcs/tig/tig-0.16.1.ebuild b/dev-vcs/tig/tig-0.16.1.ebuild
new file mode 100644
index 000000000000..9eae3b80b74b
--- /dev/null
+++ b/dev-vcs/tig/tig-0.16.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.16.1.ebuild,v 1.1 2010/09/19 20:43:14 robbat2 Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+ doman tig.1 tigrc.5 || die
+ dodoc manual.txt || die
+ dohtml manual.html || die
+ dobashcompletion contrib/tig-completion.bash
+}