summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-16 10:41:45 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-16 10:41:45 +0000
commit02191d6e6aa7c7c7c9c11cc746afa185a5106396 (patch)
tree8e1cfd3a624d4b454f6f541e9ad09efb6cc4035b /dev-vcs
parentclean old impls, rm old (diff)
downloadgentoo-2-02191d6e6aa7c7c7c9c11cc746afa185a5106396.tar.gz
gentoo-2-02191d6e6aa7c7c7c9c11cc746afa185a5106396.tar.bz2
gentoo-2-02191d6e6aa7c7c7c9c11cc746afa185a5106396.zip
dev-vcs/git-cola: Fix tests and docs
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/ChangeLog6
-rw-r--r--dev-vcs/git-cola/git-cola-2.0.7.ebuild15
-rw-r--r--dev-vcs/git-cola/git-cola-2.1.0.ebuild12
3 files changed, 21 insertions, 12 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index a6b12845e4fe..a89a8ed6660f 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.37 2015/01/16 09:38:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.38 2015/01/16 10:41:45 jlec Exp $
+
+ 16 Jan 2015; Justin Lecher <jlec@gentoo.org> git-cola-2.0.7.ebuild,
+ git-cola-2.1.0.ebuild:
+ Fix tests and docs
*git-cola-2.1.0 (16 Jan 2015)
diff --git a/dev-vcs/git-cola/git-cola-2.0.7.ebuild b/dev-vcs/git-cola/git-cola-2.0.7.ebuild
index 42e7b9896830..cb373fd720aa 100644
--- a/dev-vcs/git-cola/git-cola-2.0.7.ebuild
+++ b/dev-vcs/git-cola/git-cola-2.0.7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.0.7.ebuild,v 1.2 2015/01/16 09:38:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.0.7.ebuild,v 1.3 2015/01/16 10:41:45 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
DISTUTILS_SINGLE_IMPL=true
inherit distutils-r1 readme.gentoo virtualx
@@ -18,6 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
+REQUIRED_USE="doc? ( python_targets_python2_7 )"
+
RDEPEND="
dev-python/jsonpickle[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
@@ -27,7 +29,10 @@ DEPEND="${RDEPEND}
app-text/asciidoc
app-text/xmlto
sys-devel/gettext
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')]
+ )
test? (
dev-python/nose[${PYTHON_USEDEP}]
sys-apps/net-tools
@@ -76,8 +81,8 @@ python_compile_all() {
python_test() {
PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
- VIRTUALX_COMMAND="nosetests --verbose --with-doctest \
- --with-id --exclude=jsonpickle --exclude=json" \
+ VIRTUALX_COMMAND="nosetests --verbose \
+ --with-id --with-doctest --exclude=sphinxtogithub" \
virtualmake
}
diff --git a/dev-vcs/git-cola/git-cola-2.1.0.ebuild b/dev-vcs/git-cola/git-cola-2.1.0.ebuild
index d731af066520..b949076357e0 100644
--- a/dev-vcs/git-cola/git-cola-2.1.0.ebuild
+++ b/dev-vcs/git-cola/git-cola-2.1.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.1.0.ebuild,v 1.1 2015/01/16 09:38:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.1.0.ebuild,v 1.2 2015/01/16 10:41:45 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4} )
-PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=true
inherit distutils-r1 readme.gentoo virtualx
@@ -19,6 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
+REQUIRED_USE="doc? ( python_targets_python2_7 )"
+
RDEPEND="
dev-python/jsonpickle[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
@@ -30,11 +31,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxtogithub[${PYTHON_USEDEP}]
+ dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')]
)
test? (
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/sphinxtogithub[${PYTHON_USEDEP}]
sys-apps/net-tools
)"
@@ -81,8 +81,8 @@ python_compile_all() {
python_test() {
PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
- VIRTUALX_COMMAND="nosetests --verbose --with-doctest \
- --with-id --exclude=jsonpickle --exclude=json" \
+ VIRTUALX_COMMAND="nosetests --verbose \
+ --with-id --with-doctest --exclude=sphinxtogithub" \
virtualmake
}