summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-20 08:42:13 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-20 08:42:13 +0000
commit31b94fd2f479ae21ef706f5158e6321d64514bae (patch)
tree1fcaefe53353c049dcf4bda9fbe0ac92946fc034 /dev-vcs
parentVersion bump, drop old (diff)
downloadgentoo-2-31b94fd2f479ae21ef706f5158e6321d64514bae.tar.gz
gentoo-2-31b94fd2f479ae21ef706f5158e6321d64514bae.tar.bz2
gentoo-2-31b94fd2f479ae21ef706f5158e6321d64514bae.zip
Lower the build-time requirement of Python to Python bindings or USE=test. Add REQUIRED_USE for Python.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog6
-rw-r--r--dev-vcs/subversion/subversion-1.7.9.ebuild15
2 files changed, 16 insertions, 5 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index d06f0e7d68be..363cb58ea7d4 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.116 2013/05/05 12:10:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.117 2013/07/20 08:42:13 mgorny Exp $
+
+ 20 Jul 2013; Michał Górny <mgorny@gentoo.org> subversion-1.7.9.ebuild:
+ Lower the build-time requirement of Python to Python bindings or USE=test. Add
+ REQUIRED_USE for Python.
05 May 2013; Agostino Sarubbo <ago@gentoo.org> -subversion-1.6.17-r7.ebuild,
-subversion-1.7.6.ebuild, -subversion-1.7.7.ebuild, -subversion-1.7.8.ebuild:
diff --git a/dev-vcs/subversion/subversion-1.7.9.ebuild b/dev-vcs/subversion/subversion-1.7.9.ebuild
index 135e77edceea..77385bd4f4dd 100644
--- a/dev-vcs/subversion/subversion-1.7.9.ebuild
+++ b/dev-vcs/subversion/subversion-1.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.7.9.ebuild,v 1.14 2013/04/22 12:24:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.7.9.ebuild,v 1.15 2013/07/20 08:42:13 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="Subversion GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring java kde nls perl python ruby sasl vim-syntax +webdav-neon webdav-serf"
+IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring java kde nls perl python ruby sasl test vim-syntax +webdav-neon webdav-serf"
COMMON_DEPEND=">=dev-db/sqlite-3.4[threadsafe(+)]
>=dev-libs/apr-1.3:1
@@ -44,7 +44,7 @@ RDEPEND="${COMMON_DEPEND}
perl? ( dev-perl/URI )"
# Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
DEPEND="${COMMON_DEPEND}
- ${PYTHON_DEPS}
+ test? ( ${PYTHON_DEPS} )
!!<sys-apps/sandbox-1.6
ctypes-python? ( dev-python/ctypesgen )
doc? ( app-doc/doxygen )
@@ -54,6 +54,11 @@ DEPEND="${COMMON_DEPEND}
nls? ( sys-devel/gettext )
webdav-neon? ( virtual/pkgconfig )"
+REQUIRED_USE="
+ ctypes-python? ( ${PYTHON_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} )"
+
want_apache
pkg_setup() {
@@ -185,7 +190,9 @@ src_configure() {
myconf+=" --disable-disallowing-of-undefined-references"
# for build-time scripts
- python_export_best
+ if use ctypes-python || use python || use test; then
+ python_export_best
+ fi
#force ruby-1.8 for bug 399105
#allow overriding Python include directory