summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-09-16 11:29:12 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-09-16 11:29:12 +0000
commit89774010e79dd42eded5dd2c513a2298e4584a10 (patch)
tree45f4d691b5cfead0c1de6c751a6455ec7083fb27 /dev-vcs
parentUSE="static-libs" and punt .la files. Fix LICENSE. Remove USE="doc" as it doe... (diff)
downloadgentoo-2-89774010e79dd42eded5dd2c513a2298e4584a10.tar.gz
gentoo-2-89774010e79dd42eded5dd2c513a2298e4584a10.tar.bz2
gentoo-2-89774010e79dd42eded5dd2c513a2298e4584a10.zip
Don't use stderr anymore, bug 326279. Move sed to add 'svn mkdir' to the preventcolor array into the patch as well. Use make -j1 for now, bug 335134.
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/colorsvn/ChangeLog9
-rw-r--r--dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild49
-rw-r--r--dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch43
3 files changed, 100 insertions, 1 deletions
diff --git a/dev-vcs/colorsvn/ChangeLog b/dev-vcs/colorsvn/ChangeLog
index eadc1cf0a46a..7bef231244bf 100644
--- a/dev-vcs/colorsvn/ChangeLog
+++ b/dev-vcs/colorsvn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/colorsvn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/colorsvn/ChangeLog,v 1.4 2010/09/08 11:17:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/colorsvn/ChangeLog,v 1.5 2010/09/16 11:29:12 idl0r Exp $
+
+*colorsvn-0.3.2-r2 (16 Sep 2010)
+
+ 16 Sep 2010; Christian Ruppert <idl0r@gentoo.org> +colorsvn-0.3.2-r2.ebuild,
+ +files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch:
+ Don't use stderr anymore, bug 326279. Move sed to add 'svn mkdir' to the
+ preventcolor array into the patch as well. Use make -j1 for now, bug 335134.
08 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
colorsvn-0.3.2-r1.ebuild:
diff --git a/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild b/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..880e39ddfbb4
--- /dev/null
+++ b/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild,v 1.1 2010/09/16 11:29:12 idl0r Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Subversion output colorizer"
+HOMEPAGE="http://colorsvn.tigris.org"
+SRC_URI="http://www.console-colors.de/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-vcs/subversion"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # rxvt-unicode isn't listed by default :)
+ sed -i -e 's:rxvt:rxvt rxvt-unicode:' colorsvnrc-original || die
+
+ epatch "${FILESDIR}/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch"
+}
+
+src_compile() {
+ # bug 335134
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CREDITS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The default settings are stored in /etc/colorsvnrc."
+ einfo "They can be locally overridden by ~/.colorsvnrc."
+ einfo "An alias to colorsvn was installed for the svn command."
+ einfo "In order to immediately activate it do:"
+ einfo "\tsource /etc/profile"
+ einfo "NOTE: If you don't see colors,"
+ einfo "append the output of 'echo \$TERM' to 'colortty' in your colorsvnrc."
+ einfo
+}
diff --git a/dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch b/dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch
new file mode 100644
index 000000000000..6fb1e4b0313b
--- /dev/null
+++ b/dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch
@@ -0,0 +1,43 @@
+From 869595b958e80f8c05b823c0df514d3decbe6686 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Thu, 16 Sep 2010 13:04:25 +0200
+Subject: [PATCH] Don't colorize 'svn mkdir', bug 321451. Use IPC::open2 instead of open3 to avoid using STDERR, bug 326279.
+
+---
+ colorsvn-original | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/colorsvn-original b/colorsvn-original
+index 01d7be3..46f105b 100644
+--- a/colorsvn-original
++++ b/colorsvn-original
+@@ -56,7 +56,7 @@
+ # Foundation, Inc., 51 Franklin Steet, Fifth Floor, Boston, MA 02110-1301, USA.
+
+ use Term::ANSIColor;
+-use IPC::Open3;
++use IPC::Open2;
+
+ use strict;
+ use warnings;
+@@ -115,7 +115,7 @@ our %commandmap = ( "add" => ["add"],
+ );
+
+ # never colorize this commands
+-our @preventcolor = ("commit", "help", "import", "lock", "switch", "propedit", "resolved", "revert", "unlock");
++our @preventcolor = ("commit", "help", "import", "lock", "switch", "propedit", "resolved", "revert", "unlock", "mkdir");
+
+ #
+ # set default values
+@@ -331,7 +331,7 @@ if (! -t STDOUT || $commit == 1 || !$colortty{$terminal} || !$commresolved )
+
+ # Keep the pid of the svn process so we can get its return
+ # code and use that as our return code.
+-my $svn_pid = open3('<&STDIN', \*SVNOUT, \*SVNOUT, $svnPath, @ARGV);
++my $svn_pid = open2(\*SVNOUT, '<&STDIN', $svnPath, @ARGV);
+ my $svnName = $svnPath;
+ $svnName =~ s,.*/(.*)$,$1,;
+
+--
+1.7.2.2
+