summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-10-19 21:38:36 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-10-19 21:38:36 +0000
commit91949dce3fe957c0ae64992f5e61ad6c59ac3e3b (patch)
tree8a678036ce2492a6663aafa167b51a8969d9baaf /dev-vcs
parentVersion bump (diff)
downloadgentoo-2-91949dce3fe957c0ae64992f5e61ad6c59ac3e3b.tar.gz
gentoo-2-91949dce3fe957c0ae64992f5e61ad6c59ac3e3b.tar.bz2
gentoo-2-91949dce3fe957c0ae64992f5e61ad6c59ac3e3b.zip
Version bump. Removed old ebuild.
(Portage version: 2.2_rc94/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/ChangeLog8
-rw-r--r--dev-vcs/fossil/fossil-20101005035549.ebuild (renamed from dev-vcs/fossil/fossil-20100318142033.ebuild)17
2 files changed, 16 insertions, 9 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index 1c96898885b5..00016f484cce 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/fossil
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.3 2010/09/27 00:25:06 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.4 2010/10/19 21:38:36 rafaelmartins Exp $
+
+*fossil-20101005035549 (19 Oct 2010)
+
+ 19 Oct 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ -fossil-20100318142033.ebuild, +fossil-20101005035549.ebuild:
+ Version bump. Removed old ebuild.
*fossil-20100918155143 (27 Sep 2010)
diff --git a/dev-vcs/fossil/fossil-20100318142033.ebuild b/dev-vcs/fossil/fossil-20101005035549.ebuild
index 1ae5e9ef8d9b..85b545f13f48 100644
--- a/dev-vcs/fossil/fossil-20100318142033.ebuild
+++ b/dev-vcs/fossil/fossil-20101005035549.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20100318142033.ebuild,v 1.1 2010/05/19 07:52:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20101005035549.ebuild,v 1.1 2010/10/19 21:38:36 rafaelmartins Exp $
EAPI="2"
inherit eutils toolchain-funcs
MY_P="${PN}-src-${PV}"
+PATCH_PV="20100318142033"
DESCRIPTION="simple, high-reliability, distributed software configuration management"
HOMEPAGE="http://www.fossil-scm.org/"
@@ -17,22 +18,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
+DEPEND="dev-db/sqlite:3
dev-libs/openssl
sys-libs/zlib"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ epatch "${FILESDIR}/${PATCH_PV}-gentoo.patch"
sed -i \
-e "/^TCC *=/s:=.*:=$(tc-getCC) -Wall \$(CFLAGS) \$(CPPFLAGS):" \
-e "/^BCC/s:gcc:$(tc-getBUILD_CC):" \
- Makefile || die
+ Makefile || die 'sed failed.'
}
src_install() {
- dobin fossil || die
- dodoc ci_cvs.txt ci_fossil.txt cvs2fossil.txt || die
+ dobin fossil || die 'dobin failed.'
+ dodoc ci_cvs.txt ci_fossil.txt cvs2fossil.txt || die 'dodoc failed.'
}