summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-07-31 10:17:23 +0000
committerFabian Groffen <grobian@gentoo.org>2010-07-31 10:17:23 +0000
commitc38a479e808213e48a646d4b2749c49fbce6ca1f (patch)
tree17d2d2545653e8c45f9acc0739ef616dadec24dd /dev-vcs
parentfixes bug #313367. (diff)
downloadgentoo-2-c38a479e808213e48a646d4b2749c49fbce6ca1f.tar.gz
gentoo-2-c38a479e808213e48a646d4b2749c49fbce6ca1f.tar.bz2
gentoo-2-c38a479e808213e48a646d4b2749c49fbce6ca1f.zip
Fix compilation with USE=-iconv on non-glibc platforms since disabling of iconv is still ignored due to bugs mentioned in the ebuild
(Portage version: 2.2.01.15449-prefix/cvs/SunOS i386)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog6
-rw-r--r--dev-vcs/git/git-1.7.2-r1.ebuild8
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index d629ffe635b6..d734c6ffe3ad 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.20 2010/07/30 21:01:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.21 2010/07/31 10:17:23 grobian Exp $
+
+ 31 Jul 2010; Fabian Groffen <grobian@gentoo.org> git-1.7.2-r1.ebuild:
+ Fix compilation with USE=-iconv on non-glibc platforms since disabling of
+ iconv is still ignored due to bugs mentioned in the ebuild
30 Jul 2010; Robin H. Johnson <robbat2@gentoo.org> -git-1.6.3.1.ebuild,
-git-1.6.3.3.ebuild, -git-1.6.3.4.ebuild, -git-1.6.4.ebuild,
diff --git a/dev-vcs/git/git-1.7.2-r1.ebuild b/dev-vcs/git/git-1.7.2-r1.ebuild
index 4d8f1e6cf0d7..eae47ee4c6a4 100644
--- a/dev-vcs/git/git-1.7.2-r1.ebuild
+++ b/dev-vcs/git/git-1.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2-r1.ebuild,v 1.1 2010/07/22 21:34:50 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2-r1.ebuild,v 1.2 2010/07/31 10:17:23 grobian Exp $
EAPI=3
@@ -123,11 +123,13 @@ exportmakeopts() {
# can't define this to null, since the entire makefile depends on it
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
- use !elibc_glibc && use iconv && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
use iconv \
- || einfo "Forcing iconv for 1.7.1-r1 due to bugs #321895, #322205."
+ || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
# || myopts="${myopts} NO_ICONV=YesPlease"
+ # because, above, we need to do this unconditionally (no "&& use iconv")
+ use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
+
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \