summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-15 19:23:43 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-15 19:23:43 +0000
commitd728b9de44e3da24d2a3add719b743e0f83727df (patch)
tree47adb52592838303f38c0277b6a323f55c126415 /dev-vcs
parentapp-misc/unfoo: Drop old (diff)
downloadgentoo-2-d728b9de44e3da24d2a3add719b743e0f83727df.tar.gz
gentoo-2-d728b9de44e3da24d2a3add719b743e0f83727df.tar.bz2
gentoo-2-d728b9de44e3da24d2a3add719b743e0f83727df.zip
dev-vcs/git-cola: Version BUmp
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/ChangeLog8
-rw-r--r--dev-vcs/git-cola/git-cola-2.0.6.ebuild (renamed from dev-vcs/git-cola/git-cola-2.0.4.ebuild)14
2 files changed, 16 insertions, 6 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index 313afcd595eb..c5b7c15dfe1a 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.31 2014/08/10 07:13:51 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.32 2014/09/15 19:23:43 jlec Exp $
+
+*git-cola-2.0.6 (15 Sep 2014)
+
+ 15 Sep 2014; Justin Lecher <jlec@gentoo.org> -git-cola-2.0.4.ebuild,
+ +git-cola-2.0.6.ebuild:
+ Version BUmp
*git-cola-2.0.5-r1 (10 Aug 2014)
diff --git a/dev-vcs/git-cola/git-cola-2.0.4.ebuild b/dev-vcs/git-cola/git-cola-2.0.6.ebuild
index 9b560e310c47..6143c55f7a47 100644
--- a/dev-vcs/git-cola/git-cola-2.0.4.ebuild
+++ b/dev-vcs/git-cola/git-cola-2.0.6.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.0.4.ebuild,v 1.1 2014/06/25 13:54:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.0.6.ebuild,v 1.1 2014/09/15 19:23:43 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
DISTUTILS_SINGLE_IMPL=true
-inherit distutils-r1 readme.gentoo
+inherit distutils-r1 readme.gentoo virtualx
DESCRIPTION="The highly caffeinated git GUI"
HOMEPAGE="http://git-cola.github.com/"
@@ -86,6 +86,9 @@ python_install_all() {
prefix="${EPREFIX}/usr" \
install
+ python_fix_shebang "${D}/usr/share/git-cola/bin/git-xbase"
+ python_optimize "${D}/usr/share/git-cola/lib/cola"
+
if ! use doc ; then
HTML_DOCS=( "${FILESDIR}"/index.html )
fi
@@ -96,7 +99,8 @@ python_install_all() {
}
python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
- --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
- || die "running nosetests failed"
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
+ VIRTUALX_COMMAND="nosetests --verbose --with-doctest \
+ --with-id --exclude=jsonpickle --exclude=json" \
+ virtualmake
}