summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-08-19 10:40:54 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-08-19 10:40:54 +0000
commitf68505639adc1a8311b3a40a09b735d8799e764a (patch)
tree89dd722c3b4191a97f7e8d546eb6e1aa6e3ac45e /dev-vcs
parentrestore USE deps check for EAPI=0,1 in pkg_setup (diff)
downloadgentoo-2-f68505639adc1a8311b3a40a09b735d8799e764a.tar.gz
gentoo-2-f68505639adc1a8311b3a40a09b735d8799e764a.tar.bz2
gentoo-2-f68505639adc1a8311b3a40a09b735d8799e764a.zip
More gracefully handle dependency between KDE & NLS USE-flags, as requested by Jeroen Roovers in bug #330941. Perfection would require EAPI=4, which I can not use yet. Tell user to restart daemon after upgrade, as requested by Joel Koglin in bug #337042. Use recursive dodoc instead of ecompressdir as requested by Ulrich Müller in bug #356503. Move the environment config back to inline for now, as Kent Fredric reports that variable substitution broke and caused env-update failures. Closes bug #379819. Killed old -r1 ebuild due to this problem.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog15
-rw-r--r--dev-vcs/subversion/files/80subversion-extras3
-rw-r--r--dev-vcs/subversion/subversion-1.6.17-r2.ebuild (renamed from dev-vcs/subversion/subversion-1.6.17-r1.ebuild)26
3 files changed, 29 insertions, 15 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 13aed4469823..15301bd2f8df 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.45 2011/08/18 16:48:11 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.46 2011/08/19 10:40:53 chainsaw Exp $
+
+*subversion-1.6.17-r2 (19 Aug 2011)
+
+ 19 Aug 2011; Tony Vroon <chainsaw@gentoo.org> -files/80subversion-extras,
+ -subversion-1.6.17-r1.ebuild, +subversion-1.6.17-r2.ebuild:
+ More gracefully handle dependency between KDE & NLS USE-flags, as requested
+ by Jeroen Roovers in bug #330941. Perfection would require EAPI=4, which I
+ can not use yet. Tell user to restart daemon after upgrade, as requested by
+ Joel Koglin in bug #337042. Use recursive dodoc instead of ecompressdir as
+ requested by Ulrich Müller in bug #356503. Move the environment config back
+ to inline for now, as Kent Fredric reports that variable substitution broke
+ and caused env-update failures. Closes bug #379819. Killed old -r1 ebuild due
+ to this problem.
18 Aug 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
subversion-1.6.17.ebuild:
diff --git a/dev-vcs/subversion/files/80subversion-extras b/dev-vcs/subversion/files/80subversion-extras
deleted file mode 100644
index 5b28eb7856d9..000000000000
--- a/dev-vcs/subversion/files/80subversion-extras
+++ /dev/null
@@ -1,3 +0,0 @@
-PATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
-ROOTPATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
-
diff --git a/dev-vcs/subversion/subversion-1.6.17-r1.ebuild b/dev-vcs/subversion/subversion-1.6.17-r2.ebuild
index bf78e44bead3..9bcefc2e4c96 100644
--- a/dev-vcs/subversion/subversion-1.6.17-r1.ebuild
+++ b/dev-vcs/subversion/subversion-1.6.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.6.17-r1.ebuild,v 1.1 2011/08/18 09:51:23 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.6.17-r2.ebuild,v 1.1 2011/08/19 10:40:53 chainsaw Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -61,11 +61,6 @@ PATCHES=(
want_apache
pkg_setup() {
- if use kde && ! use nls; then
- eerror "Support for KWallet (KDE) requires Native Language Support (NLS)."
- die "Enable \"nls\" USE flag"
- fi
-
if use berkdb; then
einfo
if [[ -z "${SVN_BDB_VERSION}" ]]; then
@@ -138,6 +133,12 @@ src_configure() {
myconf+=" --without-junit"
fi
+ if use kde || use nls; then
+ myconf+=" --enable-nls"
+ else
+ myconf+=" --disable-nls"
+ fi
+
econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
$(use_with apache2 apxs "${APXS}") \
$(use_with berkdb berkeley-db "db.h:${EPREFIX}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}") \
@@ -147,7 +148,6 @@ src_configure() {
$(use_enable java javahl) \
$(use_with java jdk "${JAVA_HOME}") \
$(use_with kde kwallet) \
- $(use_enable nls) \
$(use_with sasl) \
$(use_with webdav-neon neon) \
$(use_with webdav-serf serf "${EPREFIX}/usr") \
@@ -337,7 +337,11 @@ src_install() {
# Install extra files.
if use extras; then
- doenvd "${FILESDIR}/80subversion-extras"
+ cat << EOF > 80subversion-extras
+PATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+ROOTPATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+EOF
+ doenvd 80subversion-extras
emake DESTDIR="${D}" contribdir="/usr/$(get_libdir)/subversion/bin" install-contrib || die "Installation of contrib failed"
emake DESTDIR="${D}" toolsdir="/usr/$(get_libdir)/subversion/bin" install-tools || die "Installation of tools failed"
@@ -356,9 +360,7 @@ src_install() {
if use doc; then
dohtml -r doc/doxygen/html/* || die "Installation of Subversion HTML documentation failed"
- insinto /usr/share/doc/${PF}
- doins -r notes
- ecompressdir /usr/share/doc/${PF}/notes
+ dodoc -r notes
if use java; then
java-pkg_dojavadoc doc/javadoc
@@ -405,6 +407,8 @@ pkg_postinst() {
ewarn " db4_recover -h ${SVN_REPOS_LOC}/repos"
ewarn " chown -Rf apache:apache ${SVN_REPOS_LOC}/repos"
fi
+
+ ewarn "If you run subversion as a daemon, you will need to restart it to avoid module mismatches."
}
pkg_postrm() {