summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-12-14 02:13:25 +0000
committerPeter Johanson <latexer@gentoo.org>2004-12-14 02:13:25 +0000
commit06c7813deb004b6a8aaed3f9334384be9f1e7bde (patch)
tree40fdeb5aecdd556a466ccdc10e9cec910df36027 /eclass/gtk-sharp-component.eclass
parentFix for libtool problem due to version mismatches. Thanks to DHUNCAN for prod... (diff)
downloadgentoo-2-06c7813deb004b6a8aaed3f9334384be9f1e7bde.tar.gz
gentoo-2-06c7813deb004b6a8aaed3f9334384be9f1e7bde.tar.bz2
gentoo-2-06c7813deb004b6a8aaed3f9334384be9f1e7bde.zip
Fix for libtool problem due to version mismatches. Thanks to DHUNCAN for prodding me to figure this one out.
Diffstat (limited to 'eclass/gtk-sharp-component.eclass')
-rw-r--r--eclass/gtk-sharp-component.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/gtk-sharp-component.eclass b/eclass/gtk-sharp-component.eclass
index 719cae1a7542..f75e3070cb9b 100644
--- a/eclass/gtk-sharp-component.eclass
+++ b/eclass/gtk-sharp-component.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-component.eclass,v 1.2 2004/11/19 03:08:42 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-component.eclass,v 1.3 2004/12/14 02:13:25 latexer Exp $
# Author : Peter Johanson <latexer@gentoo.org>
# Based off of original work in gst-plugins.eclass by <foser@gentoo.org>
@@ -69,16 +69,18 @@ gtk-sharp-component_src_unpack() {
GTK_SHARP_LIB_DIR="${ROOT}/usr/lib/mono/gtk-sharp${GTK_SHARP_COMPONENT_SLOT_DEC}"
unpack ${A}
- cd ${S}
+ cd ${S}
# Make the components configurable
epatch ${WORKDIR}/${MY_P}-configurable.diff
aclocal || die
+ # See bug #73563, comment #9
+ libtoolize --copy --force || die
automake || die
autoconf || die
# disable building of samples (#16015)
- sed -i -e "s:sample::" ${S}/Makefile.in || die
+ sed -i -e "s:sample::" ${S}/Makefile.in || die
cd ${S}/${GTK_SHARP_COMPONENT_BUILD_DIR}