summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-05-25 19:52:35 +0000
committerDan Armak <danarmak@gentoo.org>2005-05-25 19:52:35 +0000
commit8234699018e2444f9f8faf66ebc57a0dd9234c4e (patch)
tree917af2d78791a0d4cf0f5488f8f7edd6a6bd5bbf /eclass/kde.eclass
parentMultilib fixes. (diff)
downloadgentoo-2-8234699018e2444f9f8faf66ebc57a0dd9234c4e.tar.gz
gentoo-2-8234699018e2444f9f8faf66ebc57a0dd9234c4e.tar.bz2
gentoo-2-8234699018e2444f9f8faf66ebc57a0dd9234c4e.zip
add SRC_URI for 3.4.1
Diffstat (limited to 'eclass/kde.eclass')
-rw-r--r--eclass/kde.eclass12
1 files changed, 5 insertions, 7 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index 49f1ff2368a9..9a726757ddec 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.118 2005/05/25 16:26:40 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.119 2005/05/25 19:52:35 danarmak Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -40,7 +40,6 @@ kde_pkg_setup() {
}
kde_src_unpack() {
-
debug-print-function $FUNCNAME $*
# call base_src_unpack, which implements most of the functionality and has sections,
@@ -62,12 +61,11 @@ kde_src_unpack() {
debug-print "$FUNCNAME: touching .ui files..."
touch $UIFILES
fi
-
- # Visibility support is broken in KDE. Disable it when present until
- # upstream finds a way to get it working properly. Bug 86898.
+
+ # Visiblity stuff is way broken! Just disable it when it's present
+ # until upstream finds a way to have it working right.
if grep HAVE_GCC_VISIBILITY configure &> /dev/null || ! [[ -f configure ]]; then
- find ${S} -name configure.in.in | xargs sed -i -e \
- 's:KDE_ENABLE_HIDDEN_VISIBILITY::g'
+ find ${S} -name configure.in.in | xargs sed -i -e 's:KDE_ENABLE_HIDDEN_VISIBILITY::g'
rm -f configure
fi
}