summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-28 09:47:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-28 09:47:52 +0000
commit6a128ba2f96153854100f21fed72a0958c758aa2 (patch)
tree542bc1f5c08964aa9098e4b60f2336c9b8a4bfd2 /eclass/kde4-meta.eclass
parentFix build with glibc-2.10.1 Bug #271224 (diff)
downloadgentoo-2-6a128ba2f96153854100f21fed72a0958c758aa2.tar.gz
gentoo-2-6a128ba2f96153854100f21fed72a0958c758aa2.tar.bz2
gentoo-2-6a128ba2f96153854100f21fed72a0958c758aa2.zip
Update kde4 eclasses from kde-testing. Mostly minor sinc. Introduce support for stable koffice2
Diffstat (limited to 'eclass/kde4-meta.eclass')
-rw-r--r--eclass/kde4-meta.eclass28
1 files changed, 20 insertions, 8 deletions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index 12faf7377f92..df7da0fd73b1 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.19 2009/05/14 16:46:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.20 2009/05/28 09:47:52 scarabeus Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -155,7 +155,7 @@ fi
# @DESCRIPTION:
# All subdirectories listed here will be extracted, compiled & installed.
# $KMMODULE is always added to $KMEXTRA.
-# If the htmlhandbook USE-flag is set, and if this directory exists,
+# If the doc USE-flag is set, and if this directory exists,
# then "doc/$KMMODULE" is added to $KMEXTRA. In other cases, this should be
# handled in the ebuild.
# If the documentation is in a different subdirectory, you should add it to KMEXTRA.
@@ -404,7 +404,18 @@ kde4-meta_create_extractlists() {
esac
# Don't install cmake modules for split ebuilds, to avoid collisions.
case ${KMNAME} in
- kdebase-runtime|kdebase-workspace|kdeedu|kdegames|kdegraphics|kdepim)
+ kdepim)
+ # No need for unpack since 4.2.86
+ # Remove when 4.2 is wiped out from the tree
+ case ${PV} in
+ 4.1*|4.2.0|4.2.1|4.2.2|4.2.3|4.2.4|4.2.85)
+ KMCOMPILEONLY="${KMCOMPILEONLY}
+ cmake/modules/"
+ ;;
+ *) ;;
+ esac
+ ;;
+ kdebase-runtime|kdebase-workspace|kdeedu|kdegames|kdegraphics)
case ${PN} in
libkdegames|libkdeedu|libkworkspace)
KMEXTRA="${KMEXTRA}
@@ -577,8 +588,9 @@ kde4-meta_change_cmakelists() {
fi
# Strip EXPORT feature section from workspace for KDE4 versions > 4.1.82
if [[ ${PN} != libkworkspace ]]; then
- sed -i -e '/install(FILES ${CMAKE_CURRENT_BINARY_DIR}\/KDE4WorkspaceConfig.cmake/,/^[[:space:]]*FILE KDE4WorkspaceLibraryTargets.cmake )[[:space:]]*^/d' \
- CMakeLists.txt || die "${LINENO}: sed died in kdebase-workspace strip EXPORT section"
+ sed -i \
+ -e '/install(FILES ${CMAKE_CURRENT_BINARY_DIR}\/KDE4WorkspaceConfig.cmake/,/^[[:space:]]*FILE KDE4WorkspaceLibraryTargets.cmake )[[:space:]]*^/d' \
+ CMakeLists.txt || die "${LINENO}: sed died in kdebase-workspace strip config install and fix EXPORT section"
fi
;;
kdebase-runtime)
@@ -601,9 +613,9 @@ kde4-meta_change_cmakelists() {
kdewebdev)
# Disable hardcoded kdepimlibs check
sed -e 's/find_package(KdepimLibs REQUIRED)/macro_optional_find_package(KdepimLibs)/' \
- -e 's/find_package(LibXml2 REQUIRED)/macro_optional_find_package(LibXml2 REQUIRED)/' \
- -e 's/find_package(LibXslt REQUIRED)/macro_optional_find_package(LibXslt REQUIRED)/' \
- -e 's/find_package(Boost REQUIRED)/macro_optional_find_package(Boost REQUIRED)/' \
+ -e 's/find_package(LibXml2 REQUIRED)/macro_optional_find_package(LibXml2)/' \
+ -e 's/find_package(LibXslt REQUIRED)/macro_optional_find_package(LibXslt)/' \
+ -e 's/find_package(Boost REQUIRED)/macro_optional_find_package(Boost)/' \
-i CMakeLists.txt || die "failed to disable hardcoded checks"
;;
koffice)