summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-06-09 22:00:44 +0000
committerMichael Weber <xmw@gentoo.org>2015-06-09 22:00:44 +0000
commit5d802ae9b4ac8c13f4a963a720b4bd0db95b31dc (patch)
treed8ab75b03bbb79452a9923ce2b8ebb96790d374b /eclass/netsurf.eclass
parentVersion bump (diff)
downloadgentoo-2-5d802ae9b4ac8c13f4a963a720b4bd0db95b31dc.tar.gz
gentoo-2-5d802ae9b4ac8c13f4a963a720b4bd0db95b31dc.tar.bz2
gentoo-2-5d802ae9b4ac8c13f4a963a720b4bd0db95b31dc.zip
netsurf.eclass: Update for buildsystem-1.3
Diffstat (limited to 'eclass/netsurf.eclass')
-rw-r--r--eclass/netsurf.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/netsurf.eclass b/eclass/netsurf.eclass
index 4574ebb706a5..2b462e5fa879 100644
--- a/eclass/netsurf.eclass
+++ b/eclass/netsurf.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/netsurf.eclass,v 1.2 2014/12/24 09:58:27 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/netsurf.eclass,v 1.3 2015/06/09 22:00:44 xmw Exp $
# @ECLASS: netsurf.eclass
# @MAINTAINER:
@@ -98,6 +98,8 @@ multilib_src_configure() {
sed -e "/^libdir/s:/lib:/$(get_libdir):g" \
-i ${PN}.pc.in || die
fi
+ sed -e 's:/bin/which:which:' \
+ -i ../${NETSURF_BUILDSYSTEM}/makefiles/Makefile.tools || die
}
# @FUNCTION: netsurf_make
@@ -112,7 +114,7 @@ netsurf_make() {
fi
fi
emake CC="$(tc-getCC)" LD="$(tc-getLD)" "${netsurf_makeconf[@]}" \
- COMPONENT_TYPE=${COMPONENT_TYPE} "$@"
+ COMPONENT_TYPE=${COMPONENT_TYPE} LIBDIR="$(get_libdir)" "$@"
done
}