summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-08 01:29:20 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-08 01:29:20 +0000
commit8882cebd820fa58ff86b22c4aa5e5186c3d0c559 (patch)
tree9574ffd02996959c19f7a21394297022216fcbc9 /eclass
parentversion bump as per bug #181263 thanks cilly (diff)
downloadgentoo-2-8882cebd820fa58ff86b22c4aa5e5186c3d0c559.tar.gz
gentoo-2-8882cebd820fa58ff86b22c4aa5e5186c3d0c559.tar.bz2
gentoo-2-8882cebd820fa58ff86b22c4aa5e5186c3d0c559.zip
use use_setuptools(*args,**kwargs) as the dummy function, to prevent errors about function args
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 76f2305a02ff..29519a7e78db 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.41 2007/07/04 19:38:06 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.42 2007/07/08 01:29:20 hawking Exp $
#
# Author: Jon Nelson <jnelson@gentoo.org>
# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
@@ -41,7 +41,7 @@ distutils_src_unpack() {
# remove ez_setup stuff to prevent packages
# from installing setuptools on their own
rm -rf ez_setup*
- echo "def use_setuptools(): pass" > ez_setup.py
+ echo "def use_setuptools(*args, **kwargs): pass" > ez_setup.py
}
distutils_src_compile() {