summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-14 19:41:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-14 19:41:30 +0000
commit8701ce17b2fe2e3bfd9bdbd28dc5f26a944a96e1 (patch)
tree6fea8dc370821afee007e5c4b853ab34acbfe35b /games-action/bomberclone/bomberclone-0.11.8.ebuild
parentMove single patch from separate patches tarball into files/, blacklist sdhci ... (diff)
downloadgentoo-2-8701ce17b2fe2e3bfd9bdbd28dc5f26a944a96e1.tar.gz
gentoo-2-8701ce17b2fe2e3bfd9bdbd28dc5f26a944a96e1.tar.bz2
gentoo-2-8701ce17b2fe2e3bfd9bdbd28dc5f26a944a96e1.zip
EAPI=2; add use-based deps; also install the music (bug #254977)
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-action/bomberclone/bomberclone-0.11.8.ebuild')
-rw-r--r--games-action/bomberclone/bomberclone-0.11.8.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-action/bomberclone/bomberclone-0.11.8.ebuild b/games-action/bomberclone/bomberclone-0.11.8.ebuild
index 91aef2cbcd77..aba6bfceb750 100644
--- a/games-action/bomberclone/bomberclone-0.11.8.ebuild
+++ b/games-action/bomberclone/bomberclone-0.11.8.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bomberclone/bomberclone-0.11.8.ebuild,v 1.5 2008/06/25 19:40:31 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bomberclone/bomberclone-0.11.8.ebuild,v 1.6 2009/01/14 19:41:30 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="BomberMan clone with network game support"
@@ -14,17 +15,15 @@ KEYWORDS="amd64 ~mips ppc ppc64 x86"
IUSE="X"
DEPEND=">=media-libs/libsdl-1.1.0
- media-libs/sdl-image
- media-libs/sdl-mixer
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mikmod]
X? ( x11-libs/libXt )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- find . -type d -name CVS -exec rm -rf \{\} \; 2> /dev/null
+src_prepare() {
+ ecvs_clean
}
-src_compile() {
+src_configure() {
egamesconf \
--disable-dependency-tracking \
$(use_with X x) \
@@ -33,14 +32,14 @@ src_compile() {
-e "/PACKAGE_DATA_DIR/ s:/usr/games/share/games/:${GAMES_DATADIR}/:" \
config.h \
|| die "sed config.h failed"
- emake || die "emake failed"
}
src_install() {
dogamesbin src/${PN} || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}"
- doins -r data/{gfx,maps,player,tileset} || die "doins failed"
+ doins -r data/{gfx,maps,player,tileset,music} || die "doins failed"
+ find "${D}" -name "Makefile*" -exec rm -f '{}' +
dodoc AUTHORS ChangeLog README TODO
doicon data/pixmaps/bomberclone.png