summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-09-12 14:38:59 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-09-12 14:38:59 +0000
commitf282fc37b809df41d8a128750d32be90511056af (patch)
treefc219b319ae462f3210c772e52f25688d11a8cbc /games-action/btanks
parentClean up the misleading usage of USE=threads by separating the safe and exper... (diff)
downloadgentoo-2-f282fc37b809df41d8a128750d32be90511056af.tar.gz
gentoo-2-f282fc37b809df41d8a128750d32be90511056af.tar.bz2
gentoo-2-f282fc37b809df41d8a128750d32be90511056af.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'games-action/btanks')
-rw-r--r--games-action/btanks/ChangeLog8
-rw-r--r--games-action/btanks/btanks-0.8.7686.ebuild56
-rw-r--r--games-action/btanks/files/btanks-0.8.7686-scons-blows.patch24
3 files changed, 87 insertions, 1 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index faeebc8d29fb..f68ea327ed76 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/btanks
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.13 2008/08/04 20:47:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.14 2008/09/12 14:38:58 nyhm Exp $
+
+*btanks-0.8.7686 (12 Sep 2008)
+
+ 12 Sep 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/btanks-0.8.7686-scons-blows.patch, +btanks-0.8.7686.ebuild:
+ Version bump
*btanks-0.8.7479 (04 Aug 2008)
diff --git a/games-action/btanks/btanks-0.8.7686.ebuild b/games-action/btanks/btanks-0.8.7686.ebuild
new file mode 100644
index 000000000000..80e4439b3200
--- /dev/null
+++ b/games-action/btanks/btanks-0.8.7686.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.8.7686.ebuild,v 1.1 2008/09/12 14:38:58 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Fast 2D tank arcade game with multiplayer and split-screen modes"
+HOMEPAGE="http://btanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ media-libs/openal
+ media-libs/libsdl
+ media-libs/libvorbis
+ virtual/opengl
+ dev-libs/expat
+ media-libs/smpeg
+ media-libs/sdl-image"
+DEPEND="${RDEPEND}
+ dev-util/scons
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-scons-blows.patch
+}
+
+src_compile() {
+ scons \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ prefix="${GAMES_PREFIX}" \
+ lib_dir="$(games_get_libdir)"/${PN} \
+ plugins_dir="$(games_get_libdir)"/${PN} \
+ resources_dir="${GAMES_DATADIR}"/${PN} \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin build/release/engine/btanks || die "dogamesbin failed"
+ newgamesbin build/release/editor/bted btanksed || die "newgamesbin failed"
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe build/release/*/*.so || die "doexe failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die "doins failed"
+ newicon engine/src/bt.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Battle Tanks"
+ dodoc ChangeLog *.txt
+ prepgamesdirs
+}
diff --git a/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch b/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch
new file mode 100644
index 000000000000..81ef87bfed24
--- /dev/null
+++ b/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch
@@ -0,0 +1,24 @@
+--- SConstruct
++++ SConstruct
+@@ -90,19 +90,9 @@
+ #env.Append(CPPDEFINES = ['NDEBUG'])
+
+ else:
+- if env['gcc_visibility']:
+- env.Append(CCFLAGS=['-fvisibility=hidden']);
+- env.Append(CXXFLAGS=['-fvisibility-inlines-hidden', '-fvisibility=hidden']);
+-
+- if debug:
+- env.Append(CCFLAGS=['-ggdb', '-D_FORTIFY_SOURCE=2'])
+- env.Append(CPPFLAGS=['-ggdb', '-D_FORTIFY_SOURCE=2'])
+- else:
+- env.Append(CCFLAGS=['-O3'])
+- env.Append(CPPFLAGS=['-O3'])
+
+- env.Append(CPPFLAGS=['-Wall', '-pedantic', '-Wno-long-long', '-pipe', '-pthread'])
+- env.Append(CCFLAGS=['-Wall', '-pedantic', '-Wno-long-long', '-pipe', '-pthread'])
++ env.Append(CPPFLAGS=['-Wall', '-pedantic', '-Wno-long-long', '-pthread'])
++ env.Append(CCFLAGS=['-Wall', '-pedantic', '-Wno-long-long', '-pthread'])
+
+
+ conf_env = env.Clone()