summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-15 08:55:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-15 08:55:06 +0000
commitc32a5723c1c3579cf2b14645e72468ab9f264be3 (patch)
tree638f455ad461c55390636af5a222e660c5698762 /games-action/clanbomber
parentSLOT 0.6.x but leave 0.7.x alone #52509 / #44258 (Manifest recommit) (diff)
downloadgentoo-2-c32a5723c1c3579cf2b14645e72468ab9f264be3.tar.gz
gentoo-2-c32a5723c1c3579cf2b14645e72468ab9f264be3.tar.bz2
gentoo-2-c32a5723c1c3579cf2b14645e72468ab9f264be3.zip
work with the new 0.6.5 install style
Diffstat (limited to 'games-action/clanbomber')
-rw-r--r--games-action/clanbomber/clanbomber-1.05.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/games-action/clanbomber/clanbomber-1.05.ebuild b/games-action/clanbomber/clanbomber-1.05.ebuild
index 7504ba821fa3..d7281b9d1c85 100644
--- a/games-action/clanbomber/clanbomber-1.05.ebuild
+++ b/games-action/clanbomber/clanbomber-1.05.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-1.05.ebuild,v 1.2 2004/06/24 21:53:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-1.05.ebuild,v 1.3 2004/08/15 08:55:06 vapier Exp $
-inherit eutils games
+inherit games eutils flag-o-matic
DESCRIPTION="Bomberman-like multiplayer game"
HOMEPAGE="http://clanbomber.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/clanbomber/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 amd64"
IUSE=""
RDEPEND="sys-libs/zlib
@@ -19,27 +19,25 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-pkg_setup() {
- clanlib-config 0.6.5
-}
-
src_unpack() {
unpack ${A}
cd ${S}
sed -i \
-e 's:\(@datadir@/clanbomber/\):$(DESTDIR)\1:' \
clanbomber/{,*/}Makefile.in \
- || die "sed failed"
+ || die "sed failed"
epatch "${FILESDIR}/${PV}-no-display.patch"
}
src_compile() {
+ append-flags -I${ROOT}/usr/include/clanlib-0.6.5
+ append-ldflags -L${ROOT}/usr/lib/clanlib-0.6.5
egamesconf || die
emake -j1 || die "emake failed"
}
src_install() {
make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog IDEAS QUOTES README TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog IDEAS QUOTES README TODO
prepgamesdirs
}