summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 15:55:40 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 15:55:40 +0000
commit09e57e7149076e5cf2ce0e8a133089da1975ef71 (patch)
treee4e5ff0f1259097dc24f175cd0bd5ccafeffbbc0 /games-action/d2x
parentUpdated the ebuild with changes from Hendrik Iben <hiben@tzi.de> and Paul Bre... (diff)
downloadgentoo-2-09e57e7149076e5cf2ce0e8a133089da1975ef71.tar.gz
gentoo-2-09e57e7149076e5cf2ce0e8a133089da1975ef71.tar.bz2
gentoo-2-09e57e7149076e5cf2ce0e8a133089da1975ef71.zip
Change all instances of [ to [[.
(Portage version: 2.1.2.1)
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/ChangeLog6
-rw-r--r--games-action/d2x/d2x-0.2.5-r2.ebuild12
-rw-r--r--games-action/d2x/d2x-0.2.5-r3.ebuild6
3 files changed, 14 insertions, 10 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index a5f22ab94122..7843f4d09d26 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.17 2007/01/09 21:54:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.18 2007/03/07 15:55:40 wolf31o2 Exp $
+
+ 07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r2.ebuild,
+ d2x-0.2.5-r3.ebuild:
+ Change all instances of [ to [[.
*d2x-0.2.5-r3 (09 Jan 2007)
diff --git a/games-action/d2x/d2x-0.2.5-r2.ebuild b/games-action/d2x/d2x-0.2.5-r2.ebuild
index 72b02560c14f..8fd558451978 100644
--- a/games-action/d2x/d2x-0.2.5-r2.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r2.ebuild,v 1.5 2006/10/24 22:31:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r2.ebuild,v 1.6 2007/03/07 15:55:40 wolf31o2 Exp $
inherit flag-o-matic eutils games
@@ -29,7 +29,7 @@ src_unpack() {
if use cdinstall ; then
if [[ ! -e "${DISTDIR}"/descent2.sow ]] ; then
cdrom_get_cds d2data
- if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
+ if [[ -e ${CDROM_ROOT}/d2data/descent2.sow ]] ; then
export CDROM_ROOT=${CDROM_ROOT}/d2data
einfo "Found the original Descent2 CD"
einfo "Copying descent2.sow to ${DISTDIR}"
@@ -62,17 +62,17 @@ src_compile() {
for ren in sdl $(useq opengl && echo opengl) \
$(useq svga && echo svga) $(useq ggi && echo ggi)
do
- [ "${ren}" == "sdl" ] \
+ [[ "${ren}" == "sdl" ]] \
&& renconf="" \
|| renconf="--with-${ren}"
- [ "${ren}" == "svga" ] \
+ [[ "${ren}" == "svga" ]] \
&& defflags="-DSVGALIB_INPUT" \
|| defflags=""
make distclean
egamesconf \
${myconf} \
${renconf} \
- --datadir=${GAMES_DATADIR_BASE} \
+ --datadir="${GAMES_DATADIR_BASE}" \
|| die "conf ${ren}"
emake CXXFLAGS="${CXXFLAGS} ${defflags}" || die "build ${ren}"
mv d2x* my-bins/
diff --git a/games-action/d2x/d2x-0.2.5-r3.ebuild b/games-action/d2x/d2x-0.2.5-r3.ebuild
index e66bb40d5fe5..79430b5b39aa 100644
--- a/games-action/d2x/d2x-0.2.5-r3.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.1 2007/01/09 21:54:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.2 2007/03/07 15:55:40 wolf31o2 Exp $
inherit eutils flag-o-matic games
@@ -48,10 +48,10 @@ src_compile() {
mkdir my-bins
for ren in sdl $(useq opengl && echo opengl) \
$(useq svga && echo svga) $(useq ggi && echo ggi) ; do
- [ "${ren}" == "sdl" ] \
+ [[ "${ren}" == "sdl" ]] \
&& renconf="" \
|| renconf="--with-${ren}"
- [ "${ren}" == "svga" ] \
+ [[ "${ren}" == "svga" ]] \
&& defflags="-DSVGALIB_INPUT" \
|| defflags=""
make distclean