summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-14 00:34:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-14 00:34:36 +0000
commit18bb1bb3264281199ea26b0904b88fac9f7c9af8 (patch)
tree91b7b216177f9dd58a0a0c94de2bfdb6cacfb30b /games-action/gltron/gltron-0.70-r1.ebuild
parentStable on alpha wrt bug #165798. (diff)
downloadgentoo-2-18bb1bb3264281199ea26b0904b88fac9f7c9af8.tar.gz
gentoo-2-18bb1bb3264281199ea26b0904b88fac9f7c9af8.tar.bz2
gentoo-2-18bb1bb3264281199ea26b0904b88fac9f7c9af8.zip
Move icon to mirror://gentoo
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-action/gltron/gltron-0.70-r1.ebuild')
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild31
1 files changed, 11 insertions, 20 deletions
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
index 468e4b08e4a9..10d08dc57673 100644
--- a/games-action/gltron/gltron-0.70-r1.ebuild
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.4 2006/07/25 07:00:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.5 2007/02/14 00:34:36 nyhm Exp $
inherit eutils games
DESCRIPTION="3d tron, just like the movie"
HOMEPAGE="http://gltron.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gltron/${P}-source.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz
+ mirror://gentoo/${PN}.png"
LICENSE="GPL-2"
SLOT="0"
@@ -14,16 +15,16 @@ KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND="virtual/opengl
- sys-libs/zlib
media-libs/libpng
- >=media-libs/libsdl-1.2
+ media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-sound"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-configure.patch \
+ epatch \
+ "${FILESDIR}"/${P}-configure.patch \
"${FILESDIR}"/${P}-prototypes.patch \
"${FILESDIR}"/${P}-debian.patch
}
@@ -36,24 +37,14 @@ src_compile() {
--disable-debug \
--disable-profile \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog README
dohtml *.html
- doicon ${FILESDIR}/${PN}.png
- make_desktop_entry ${PN} GLtron ${PN}.png
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} GLtron
prepgamesdirs
}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- if ! use mikmod ; then
- echo
- ewarn "Since you don't have the mikmod USE flag set, there won't"
- ewarn "be any in-game music for ${PN}."
- fi
-}