summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 04:53:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 04:53:52 +0000
commitade8af9550ba497516bf22cbc2c67c7ff97bca02 (patch)
tree201ae50a058894f70b956bd804fc8bb501a4a6c6 /games-action/gltron/gltron-0.70-r1.ebuild
parentFix CFLAGS breakage and sync some mismatched prototypes. (diff)
downloadgentoo-2-ade8af9550ba497516bf22cbc2c67c7ff97bca02.tar.gz
gentoo-2-ade8af9550ba497516bf22cbc2c67c7ff97bca02.tar.bz2
gentoo-2-ade8af9550ba497516bf22cbc2c67c7ff97bca02.zip
Add fixes from Debian for amd64 support #100109 Micha Wiernowolski.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-action/gltron/gltron-0.70-r1.ebuild')
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
new file mode 100644
index 000000000000..033ddc4ddb66
--- /dev/null
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.1 2005/07/30 04:53:52 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="3d tron, just like the movie"
+HOMEPAGE="http://gltron.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gltron/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/opengl
+ sys-libs/zlib
+ media-libs/libpng
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-mixer
+ media-libs/sdl-sound"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-prototypes.patch
+ epatch "${FILESDIR}"/${P}-debian.patch
+}
+
+src_compile() {
+ # warn/debug/profile just modify CFLAGS, they aren't
+ # real options, so don't utilize USE flags here
+ egamesconf \
+ --disable-warn \
+ --disable-debug \
+ --disable-profile \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README
+ dohtml *.html
+ prepgamesdirs
+}