summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-25 20:54:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-25 20:54:31 +0000
commit81b7986900d2e4dff28e3c6e798786c7ee67c35d (patch)
tree839b79f23d89039d4c21cec7d436e1f3f63967cf /games-action/maelstrom
parentDropped ppc-macos, see you in prefix. (diff)
downloadgentoo-2-81b7986900d2e4dff28e3c6e798786c7ee67c35d.tar.gz
gentoo-2-81b7986900d2e4dff28e3c6e798786c7ee67c35d.tar.bz2
gentoo-2-81b7986900d2e4dff28e3c6e798786c7ee67c35d.zip
Fix for fail to compile on a 64 bits CPU. Bug #146153
(Portage version: 2.1.1)
Diffstat (limited to 'games-action/maelstrom')
-rw-r--r--games-action/maelstrom/ChangeLog8
-rw-r--r--games-action/maelstrom/files/digest-maelstrom-3.0.6-r12
-rw-r--r--games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch15
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6-r1.ebuild5
4 files changed, 26 insertions, 4 deletions
diff --git a/games-action/maelstrom/ChangeLog b/games-action/maelstrom/ChangeLog
index b8d6f6c67cdc..828bbc56584c 100644
--- a/games-action/maelstrom/ChangeLog
+++ b/games-action/maelstrom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/maelstrom
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.17 2005/08/15 19:03:08 mr_bones_ Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.18 2006/10/25 20:54:31 tupone Exp $
+
+ 25 Oct 2006; <tupone@gentoo.org> +files/maelstrom-3.0.6-64bits.patch,
+ maelstrom-3.0.6-r1.ebuild:
+ Fix for fail to compile on a 64 bits CPU. Bug #146153 by Randall Nortman
15 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org>
maelstrom-3.0.6-r1.ebuild:
diff --git a/games-action/maelstrom/files/digest-maelstrom-3.0.6-r1 b/games-action/maelstrom/files/digest-maelstrom-3.0.6-r1
index 1fbf791cebf6..14b5f526d05d 100644
--- a/games-action/maelstrom/files/digest-maelstrom-3.0.6-r1
+++ b/games-action/maelstrom/files/digest-maelstrom-3.0.6-r1
@@ -1 +1,3 @@
MD5 8aab0e75ca52808fd6777535ebb1f1c4 Maelstrom-3.0.6.tar.gz 1007421
+RMD160 9415324e96fdccfc5ff5c453e886d0ce28956c13 Maelstrom-3.0.6.tar.gz 1007421
+SHA256 bb6ca1952d1080e25f8716a2d08a4241614ee72d54f13c8a60eecadf7ea6198d Maelstrom-3.0.6.tar.gz 1007421
diff --git a/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch b/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch
new file mode 100644
index 000000000000..bdf04d3ad30d
--- /dev/null
+++ b/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch
@@ -0,0 +1,15 @@
+--- screenlib/SDL_FrameBuf.cpp.old 2006-10-25 22:37:21.000000000 +0200
++++ screenlib/SDL_FrameBuf.cpp 2006-10-25 22:38:26.000000000 +0200
+@@ -847,10 +847,8 @@
+ /* Update the dirty rectangle map with the new list */
+ for ( i=0; i<dirtymaplen; ++i ) {
+ if ( dirtymap[i] != NULL ) {
+- dirtymap[i] = (SDL_Rect *)(
+- ((int)dirtymap[i]-(int)updatelist) +
+- (int)newlist
+- );
++ dirtymap[i] = newlist
++ + (dirtymap[i]-updatelist);
+ }
+ }
+ delete[] updatelist;
diff --git a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
index 8193c59d9898..1db3d5f52803 100644
--- a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
+++ b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.8 2005/08/15 19:03:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.9 2006/10/25 20:54:31 tupone Exp $
inherit eutils games
@@ -25,6 +25,7 @@ src_unpack() {
epatch \
"${FILESDIR}"/${PF}-security.patch \
+ "${FILESDIR}"/${P}-64bits.patch \
"${FILESDIR}"/${PN}-gcc34.patch
# Install the data into $(datadir)/..., not $(prefix)/games/...