summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-23 01:40:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-23 01:40:57 +0000
commit642aedfac893e9ef0366ea589498603529317485 (patch)
treecece566a3f09690e27d786b124d60950e5f0f45d /games-action/rafkill
parentjust pass -j to scons from MAKEOPTS (diff)
downloadgentoo-2-642aedfac893e9ef0366ea589498603529317485.tar.gz
gentoo-2-642aedfac893e9ef0366ea589498603529317485.tar.bz2
gentoo-2-642aedfac893e9ef0366ea589498603529317485.zip
just pass -j to scons from MAKEOPTS
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-action/rafkill')
-rw-r--r--games-action/rafkill/rafkill-1.2.3.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/games-action/rafkill/rafkill-1.2.3.ebuild b/games-action/rafkill/rafkill-1.2.3.ebuild
index b96cdef94ed9..1da96157efbf 100644
--- a/games-action/rafkill/rafkill-1.2.3.ebuild
+++ b/games-action/rafkill/rafkill-1.2.3.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.3 2008/04/30 16:46:31 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.4 2009/11/23 01:40:57 mr_bones_ Exp $
+EAPI=2
inherit eutils toolchain-funcs games
DESCRIPTION="space shoot-em-up game"
@@ -18,20 +19,21 @@ RDEPEND="media-libs/allegro
DEPEND="${RDEPEND}
dev-util/scons"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
rm -f {data,music}/.sconsign
epatch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-gcc43.patch
- sed -i "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \
- src/defs.cpp || die "sed failed"
+ sed -i \
+ -e "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \
+ src/defs.cpp \
+ || die "sed failed"
}
src_compile() {
- tc-export CXX
- scons || die "scons failed"
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+
+ scons ${sconsopts} || die "scons failed"
}
src_install() {