summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-09 17:14:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-09 17:14:46 +0000
commitf199b26bba5d0466f08ba6f5682f4dd3277e14aa (patch)
tree7ad64055fb6bb34210787e38722910b5386dd86f /games-action/slune
parentstable x86, security bug 336396 (diff)
downloadgentoo-2-f199b26bba5d0466f08ba6f5682f4dd3277e14aa.tar.gz
gentoo-2-f199b26bba5d0466f08ba6f5682f4dd3277e14aa.tar.bz2
gentoo-2-f199b26bba5d0466f08ba6f5682f4dd3277e14aa.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action/slune')
-rw-r--r--games-action/slune/ChangeLog8
-rw-r--r--games-action/slune/slune-1.0.11.ebuild6
-rw-r--r--games-action/slune/slune-1.0.15.ebuild35
3 files changed, 45 insertions, 4 deletions
diff --git a/games-action/slune/ChangeLog b/games-action/slune/ChangeLog
index 180f723e8771..817ef7e602db 100644
--- a/games-action/slune/ChangeLog
+++ b/games-action/slune/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/slune
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/slune/ChangeLog,v 1.16 2010/05/04 06:13:43 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/ChangeLog,v 1.17 2010/09/09 17:14:46 mr_bones_ Exp $
+
+*slune-1.0.15 (09 Sep 2010)
+
+ 09 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> slune-1.0.11.ebuild,
+ +slune-1.0.15.ebuild:
+ version bump
04 May 2010; Tupone Alfredo <tupone@gentoo.org> slune-1.0.11.ebuild:
Force python2 fixing bug #312229 by arfrever@gentoo.org
diff --git a/games-action/slune/slune-1.0.11.ebuild b/games-action/slune/slune-1.0.11.ebuild
index b959e72634a6..dae7be56293a 100644
--- a/games-action/slune/slune-1.0.11.ebuild
+++ b/games-action/slune/slune-1.0.11.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.11.ebuild,v 1.3 2010/05/04 06:13:43 tupone Exp $
-EAPI="2"
-PYTHON_DEPEND="2"
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.11.ebuild,v 1.4 2010/09/09 17:14:46 mr_bones_ Exp $
+EAPI=2
+PYTHON_DEPEND="2"
inherit python distutils
DESCRIPTION="A 3D action game with multiplayer mode and amazing graphics"
diff --git a/games-action/slune/slune-1.0.15.ebuild b/games-action/slune/slune-1.0.15.ebuild
new file mode 100644
index 000000000000..aad7cf9e56a4
--- /dev/null
+++ b/games-action/slune/slune-1.0.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.15.ebuild,v 1.1 2010/09/09 17:14:46 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+inherit python distutils
+
+DESCRIPTION="A 3D action game with multiplayer mode and amazing graphics"
+HOMEPAGE="http://oomadness.tuxfamily.org/en/slune/"
+SRC_URI="http://download.gna.org/slune/Slune-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.6
+ >=dev-python/soya-0.9
+ >=dev-python/py2play-0.1.9
+ >=dev-python/pyopenal-0.1.3
+ >=dev-python/pyogg-1.1
+ >=dev-python/pyvorbis-1.1"
+
+S=${WORKDIR}/Slune-${PV}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+}