summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-31 16:59:14 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-31 16:59:14 +0000
commit50a2859025ad38938291234a99cc345cec5d23c1 (patch)
treed0008d67f4fd87b8579062b0c511ffd8c644b38c /games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild
parentAdded 'ECVS_AUTH="ext"' to allow checkouts, as Savannah now uses SSH for CVS. (diff)
downloadgentoo-2-50a2859025ad38938291234a99cc345cec5d23c1.tar.gz
gentoo-2-50a2859025ad38938291234a99cc345cec5d23c1.tar.bz2
gentoo-2-50a2859025ad38938291234a99cc345cec5d23c1.zip
lets by FHS friendly
Diffstat (limited to 'games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild')
-rw-r--r--games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild b/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..44de5169a9b2
--- /dev/null
+++ b/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r1.ebuild,v 1.1 2003/12/31 16:59:14 vapier Exp $
+
+inherit games eutils
+
+MY_P=SpaceAryarya-KXL-${PV}
+DESCRIPTION="A 2D/3D shooting game"
+HOMEPAGE="http://kxl.hn.org/"
+SRC_URI="http://kxl.hn.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND=">=dev-games/KXL-1.1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ aclocal || die "aclocal failed"
+ automake -a || die "automake failed"
+ autoconf || die "autoconf failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc ChangeLog COPYING README
+ prepgamesdirs
+}