summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-19 08:23:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-19 08:23:14 +0000
commit21ce2cd76ab2ace4da46e9728784da04a29fd5b4 (patch)
tree39c50b71598604951d87c6d6febb91fecdd8d18a /games-action/tuxkart/tuxkart-0.2.0.ebuild
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-21ce2cd76ab2ace4da46e9728784da04a29fd5b4.tar.gz
gentoo-2-21ce2cd76ab2ace4da46e9728784da04a29fd5b4.tar.bz2
gentoo-2-21ce2cd76ab2ace4da46e9728784da04a29fd5b4.zip
version bump (bug #49206)
Diffstat (limited to 'games-action/tuxkart/tuxkart-0.2.0.ebuild')
-rw-r--r--games-action/tuxkart/tuxkart-0.2.0.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/games-action/tuxkart/tuxkart-0.2.0.ebuild b/games-action/tuxkart/tuxkart-0.2.0.ebuild
index 905fbdb733b5..704e9e6b2b70 100644
--- a/games-action/tuxkart/tuxkart-0.2.0.ebuild
+++ b/games-action/tuxkart/tuxkart-0.2.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/tuxkart/tuxkart-0.2.0.ebuild,v 1.7 2004/04/19 20:55:44 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/tuxkart/tuxkart-0.2.0.ebuild,v 1.8 2004/06/19 08:23:14 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="A racing game starring Tux, the linux penguin"
-SRC_URI="mirror://sourceforge/tuxkart/${P}.tar.gz"
HOMEPAGE="http://tuxkart.sourceforge.net"
+SRC_URI="mirror://sourceforge/tuxkart/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 alpha amd64"
IUSE=""
@@ -21,27 +21,28 @@ DEPEND=">=media-libs/plib-1.6.0
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/01tuxkart.patch
+ epatch "${FILESDIR}/01tuxkart.patch"
# apparently <sys/perm.h> doesn't exist on alpha
if use alpha; then
- epatch ${FILESDIR}/tuxkart-0.2.0-alpha.patch
+ epatch "${FILESDIR}/tuxkart-0.2.0-alpha.patch"
fi
sed -i \
- -e "s/-malign-double//; s/-O6//" ${S}/configure || \
- die "sed configure failed"
+ -e "/^plib_suffix/ s/-lplibul/-lplibul -lplibjs/" \
+ -e "s/-malign-double//; s/-O6//" "${S}/configure" \
+ || die "sed configure failed"
}
src_compile() {
- egamesconf --datadir=${GAMES_DATADIR_BASE} || die
+ egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS CHANGES README || die "dodoc failed"
- dohtml doc/*.html || die "dohtml failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS CHANGES README
+ dohtml doc/*.html
rm -rf "${D}/usr/share/tuxkart/"
prepgamesdirs