summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-16 22:30:01 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-16 22:30:01 +0000
commit0535d8e2afadc86fa4ba6c95b743c55d21189d2c (patch)
treeacad01f6c6ebe1dff757377d6d59c9c583c37147 /games-action
parentDelete older ebuilds. (diff)
downloadgentoo-2-0535d8e2afadc86fa4ba6c95b743c55d21189d2c.tar.gz
gentoo-2-0535d8e2afadc86fa4ba6c95b743c55d21189d2c.tar.bz2
gentoo-2-0535d8e2afadc86fa4ba6c95b743c55d21189d2c.zip
New package.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/shadowgrounds-bin/ChangeLog10
-rw-r--r--games-action/shadowgrounds-bin/metadata.xml5
-rw-r--r--games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/games-action/shadowgrounds-bin/ChangeLog b/games-action/shadowgrounds-bin/ChangeLog
new file mode 100644
index 000000000000..ed229031977e
--- /dev/null
+++ b/games-action/shadowgrounds-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/shadowgrounds-bin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-bin/ChangeLog,v 1.1 2011/04/16 22:30:01 vapier Exp $
+
+*shadowgrounds-bin-0_beta12 (16 Apr 2011)
+
+ 16 Apr 2011; Mike Frysinger <vapier@gentoo.org>
+ +shadowgrounds-bin-0_beta12.ebuild, +metadata.xml:
+ New package.
+
diff --git a/games-action/shadowgrounds-bin/metadata.xml b/games-action/shadowgrounds-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/shadowgrounds-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12.ebuild b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12.ebuild
new file mode 100644
index 000000000000..e8bad9549a50
--- /dev/null
+++ b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12.ebuild,v 1.1 2011/04/16 22:30:01 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="an epic action experience combining modern technology with addictive playability"
+HOMEPAGE="http://shadowgroundsgame.com/"
+SRC_URI="Shadowgrounds${PV/*_b/B}.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unzip -q "${DISTDIR}/${A}"
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+}
+
+src_install() {
+ local b bb
+
+ doicon Shadowgrounds.xpm || die
+ for b in bin launcher ; do
+ bb="shadowgrounds-${b}"
+ exeinto ${d}
+ newexe ${bb} ${bb} || die
+ games_make_wrapper ${bb} "./${bb}" "${d}" || die
+ make_desktop_entry ${bb} "Shadowgrounds ${b}" Shadowgrounds
+ done
+
+ exeinto ${d}/lib32
+ doexe lib32/* || die
+
+ insinto ${d}
+ doins -r Config data Profiles *.fbz *.glade *-logo.png || die
+
+ prepgamesdirs
+}