summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-07 09:32:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-07 09:32:13 +0000
commit28e2e3dfe9a44eaed5c335485ad338bbe5e8e91f (patch)
treeafb3ca0cc1cce5d3823dfa03352cf8f4ce466493 /games-action
parentfixes bug #73330 (Manifest recommit) (diff)
downloadgentoo-2-28e2e3dfe9a44eaed5c335485ad338bbe5e8e91f.tar.gz
gentoo-2-28e2e3dfe9a44eaed5c335485ad338bbe5e8e91f.tar.bz2
gentoo-2-28e2e3dfe9a44eaed5c335485ad338bbe5e8e91f.zip
use more games eclass; tidy
Diffstat (limited to 'games-action')
-rw-r--r--games-action/armagetron/ChangeLog6
-rw-r--r--games-action/armagetron/armagetron-0.2.6.0.ebuild46
2 files changed, 24 insertions, 28 deletions
diff --git a/games-action/armagetron/ChangeLog b/games-action/armagetron/ChangeLog
index 9e991671d6a2..57fd4cc07bcb 100644
--- a/games-action/armagetron/ChangeLog
+++ b/games-action/armagetron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/armagetron
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/ChangeLog,v 1.5 2004/06/24 21:51:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/ChangeLog,v 1.6 2004/12/07 09:32:13 mr_bones_ Exp $
+
+ 07 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ armagetron-0.2.6.0.ebuild:
+ use more games eclass; tidy
23 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml:
add game team to the metadata file in addition to Luke-Jr.
diff --git a/games-action/armagetron/armagetron-0.2.6.0.ebuild b/games-action/armagetron/armagetron-0.2.6.0.ebuild
index 72ff1df004df..379d49977878 100644
--- a/games-action/armagetron/armagetron-0.2.6.0.ebuild
+++ b/games-action/armagetron/armagetron-0.2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.6.0.ebuild,v 1.6 2004/06/24 21:51:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.6.0.ebuild,v 1.7 2004/12/07 09:32:13 mr_bones_ Exp $
inherit games flag-o-matic
@@ -22,45 +22,37 @@ RDEPEND="virtual/x11
sys-libs/zlib
media-libs/libpng"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
app-arch/unzip"
src_unpack() {
- unpack ${PN}-${PV}.tar.bz2
- unpack moviesounds_fq.zip
- unpack moviepack.zip
+ unpack ${A}
set > /tmp/emerge-env.txt
- cd ${S}
+ cd "${S}"
# Uses $SYNC which which conflicts with emerge
sed -i \
- -e 's/$(SYNC)/$(SYNCDISK)/' Makefile.global.in || \
- die 'sed Makefile.global.in failed'
-}
-
-src_compile() {
+ -e 's/$(SYNC)/$(SYNCDISK)/' Makefile.global.in \
+ || die 'sed Makefile.global.in failed'
filter-flags -fno-exceptions
- egamesconf || die
- emake || die
}
src_install() {
# make install for armagetron is non-existant
- dodir ${GAMES_BINDIR}
- dodir ${GAMES_LIBDIR}/${PN}
- dodir ${GAMES_DATADIR}/${PN}
- dodir /usr/share/fonts
- cp src/tron/armagetron ${D}/${GAMES_LIBDIR}/${PN} || die "No Armagetron Executable"
+ dodir "${GAMES_LIBDIR}/${PN}" "${GAMES_DATADIR}/${PN}" /usr/share/fonts
+ cp src/tron/armagetron "${D}/${GAMES_LIBDIR}/${PN}" \
+ || die "cp failed"
cp -r arenas models sound textures language config \
- ${D}/${GAMES_DATADIR}/${PN}/ || die "Missing ArmageTRON data"
+ "${D}/${GAMES_DATADIR}/${PN}/" \
+ || die "cp failed"
# maybe convert this to a .png or something
#cp tron.ico ${D}/${GAMES_DATADIR}/${PN}
dohtml doc
- newgamesbin ${FILESDIR}/${PN}-0.2.4-r1.sh ${PN} || die "ArmageTRON shell script not found"
- dosed "s:DATADIR:${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/${PN}
- dosed "s:BINDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/${PN}
- cp -r ../moviepack ${D}/${GAMES_DATADIR}/${PN}
- cp -r ../moviesounds ${D}/${GAMES_DATADIR}/${PN}
- chmod -R a+r ${D}
- chmod a+rx ${D}/${GAMES_BINDIR}/${PN}
- chmod a+rx ${D}/${GAMES_LIBDIR}/${PN}/${PN}
+ newgamesbin "${FILESDIR}/${PN}-0.2.4-r1.sh" ${PN} \
+ || die "newgamesbin failed"
+ sed -i \
+ -e "s:DATADIR:${GAMES_DATADIR}/${PN}:" \
+ -e "s:BINDIR:${GAMES_LIBDIR}/${PN}:" "${D}${GAMES_BINDIR}/${PN}" \
+ || die "sed failed"
+ cp -r ../moviepack "${D}/${GAMES_DATADIR}/${PN}" || die "cp failed"
+ cp -r ../moviesounds "${D}/${GAMES_DATADIR}/${PN}" || die "cp failed"
+ prepgamesdirs
}