summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-02-15 23:23:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-02-15 23:23:18 +0000
commit75234f4fdd4af7d96bf698205ea28a00778356f6 (patch)
tree31d57f34797c2a8d02d3dcb7973d7b3b322dfe50 /games-action
parentmakefile fix re-added for asterisk-0.7.2 (Manifest recommit) (diff)
downloadgentoo-2-75234f4fdd4af7d96bf698205ea28a00778356f6.tar.gz
gentoo-2-75234f4fdd4af7d96bf698205ea28a00778356f6.tar.bz2
gentoo-2-75234f4fdd4af7d96bf698205ea28a00778356f6.zip
Updated to use new cdrom_get_cds routine in eutils.eclass.
Diffstat (limited to 'games-action')
-rw-r--r--games-action/fakk2/ChangeLog7
-rw-r--r--games-action/fakk2/fakk2-1.02.ebuild18
-rw-r--r--games-action/heavygear2/ChangeLog7
-rw-r--r--games-action/heavygear2/heavygear2-1.0b.ebuild22
4 files changed, 30 insertions, 24 deletions
diff --git a/games-action/fakk2/ChangeLog b/games-action/fakk2/ChangeLog
index b3d6a9233792..2f9516817c66 100644
--- a/games-action/fakk2/ChangeLog
+++ b/games-action/fakk2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/fakk2
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.2 2003/09/10 20:28:08 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.3 2004/02/15 23:20:02 wolf31o2 Exp $
+
+ 15 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org> fakk2-1.02.ebuild:
+ Updated to use new cdrom_get_cds routine in eutils.eclass.
*fakk2-1.02 (05 Aug 2003)
diff --git a/games-action/fakk2/fakk2-1.02.ebuild b/games-action/fakk2/fakk2-1.02.ebuild
index b7464ac0dd4b..e00a7ff946a3 100644
--- a/games-action/fakk2/fakk2-1.02.ebuild
+++ b/games-action/fakk2/fakk2-1.02.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.2 2004/02/15 23:20:02 wolf31o2 Exp $
inherit games
@@ -24,27 +24,27 @@ dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
pkg_setup() {
+ check_license || die "License check failed"
if [ "`use nocd`" ]; then
ewarn "The installed game takes about 378MB of space!"
fi
+ cdrom_get_cds fakk
games_pkg_setup
}
src_install() {
dodir ${dir}
- games_get_cd fakk
- games_verify_cd "Heavy Metal: FAKK2"
einfo "Copying files... this may take a while..."
exeinto /opt/fakk2
- doexe ${GAMES_CD}/bin/x86/glibc-2.1/fakk2
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk2
insinto /opt/fakk2
- doins ${GAMES_CD}/{README,icon.{bmp,xpm}}
+ doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
dodir ${dir}/fakk
exeinto /opt/fakk2/fakk
- doexe ${GAMES_CD}/bin/x86/glibc-2.1/fakk/{c,f}game.so
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
if [ "`use nocd`" ]; then
insinto /opt/fakk2/fakk
- doins ${GAMES_CD}/fakk/pak{0,1,2,3}.pk3
+ doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
fi
# now, since these files are coming off a cd, the times/sizes/md5sums wont
@@ -56,7 +56,7 @@ src_install() {
dogamesbin ${FILESDIR}/fakk2
dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/fakk2
insinto /usr/share/pixmaps
- newins ${GAMES_CD}/icon.xpm fakk2.xpm
+ newins ${CDROM_ROOT}/icon.xpm fakk2.xpm
prepgamesdirs
make_desktop_entry fakk2 "FAKK2" "fakk2.xpm"
diff --git a/games-action/heavygear2/ChangeLog b/games-action/heavygear2/ChangeLog
index 0505c9024a7b..8b99d57cf051 100644
--- a/games-action/heavygear2/ChangeLog
+++ b/games-action/heavygear2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/heavygear2
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/ChangeLog,v 1.3 2003/10/17 17:40:25 wolf31o2 Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/ChangeLog,v 1.4 2004/02/15 23:23:18 wolf31o2 Exp $
+
+ 15 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org> heavygear2-1.0b.ebuild:
+ Updated to use new cdrom_get_cds routine in eutils.eclass.
17 Oct 2003; Chris Gianelloni <wolf31o2@gentoo.org> heavygear2-1.0b.ebuild:
Adding RDEPEND on freetype-1* and closing bug #27587.
diff --git a/games-action/heavygear2/heavygear2-1.0b.ebuild b/games-action/heavygear2/heavygear2-1.0b.ebuild
index f72b88bddb67..be530afc7fac 100644
--- a/games-action/heavygear2/heavygear2-1.0b.ebuild
+++ b/games-action/heavygear2/heavygear2-1.0b.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/heavygear2-1.0b.ebuild,v 1.2 2003/10/17 17:40:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/heavygear2-1.0b.ebuild,v 1.3 2004/02/15 23:23:18 wolf31o2 Exp $
inherit games
@@ -26,6 +26,8 @@ dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
pkg_setup() {
+ check_license || die "License check failed"
+ cdrom_get_cds shell/movies/asteroid.mpg
if [ "`use videos`" ]; then
ewarn "The installed game takes about 500MB of space!"
else
@@ -40,22 +42,20 @@ src_unpack() {
src_install() {
dodir ${dir}
- games_get_cd shell/movies/asteroid.mpg
- games_verify_cd "Heavy Gear II"
einfo "Copying files... this may take a while..."
exeinto /opt/heavygear2
- doexe ${GAMES_CD}/bin/x86/glibc-2.1/hg2
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/hg2
insinto /opt/heavygear2
- use 3dfx && doins ${GAMES_CD}/bin/x86/glibc-2.1/LibMesaVoodooGL.so.1.2.030300
+ use 3dfx && doins ${CDROM_ROOT}/bin/x86/glibc-2.1/LibMesaVoodooGL.so.1.2.030300
- cp ${GAMES_CD}/{README,icon.{bmp,xpm}} ${Ddir}
- use videos && cp -r ${GAMES_CD}/shell ${Ddir}
+ cp ${CDROM_ROOT}/{README,icon.{bmp,xpm}} ${Ddir}
+ use videos && cp -r ${CDROM_ROOT}/shell ${Ddir}
cd ${Ddir}
use 3dfx && dosym LibMesaVoodooGL.so.1.2.030300 libGL.so.1
- tar xzf ${GAMES_CD}/data.tar.gz || die "uncompressing data"
- tar xzf ${GAMES_CD}/binaries.tar.gz || die "uncompressing binaries"
+ tar xzf ${CDROM_ROOT}/data.tar.gz || die "uncompressing data"
+ tar xzf ${CDROM_ROOT}/binaries.tar.gz || die "uncompressing binaries"
cd ${S}
bin/Linux/x86/loki_patch --verify patch.dat
@@ -70,7 +70,7 @@ src_install() {
dogamesbin ${FILESDIR}/hg2
dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/hg2
insinto /usr/share/pixmaps
- newins ${GAMES_CD}/icon.xpm HG2.xpm
+ newins ${CDROM_ROOT}/icon.xpm HG2.xpm
prepgamesdirs
make_desktop_entry hg2 "Heavy Gear II" "HG2.xpm"