summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-10-22 05:31:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-10-22 05:31:14 +0000
commit7925419f0b509bd1ec1947262cf33ad696823954 (patch)
tree3bf9e5481e2f1bcc41811b80bcbe6772f2699e1c /games-action
parentVersion bump (bug #437808). (diff)
downloadgentoo-2-7925419f0b509bd1ec1947262cf33ad696823954.tar.gz
gentoo-2-7925419f0b509bd1ec1947262cf33ad696823954.tar.bz2
gentoo-2-7925419f0b509bd1ec1947262cf33ad696823954.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/atanks/ChangeLog8
-rw-r--r--games-action/atanks/atanks-5.6.ebuild54
2 files changed, 60 insertions, 2 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index 2f8050fa0d37..3f23c39cf68d 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/atanks
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.78 2012/07/16 19:07:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.79 2012/10/22 05:31:14 mr_bones_ Exp $
+
+*atanks-5.6 (22 Oct 2012)
+
+ 22 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org> +atanks-5.6.ebuild:
+ version bump
16 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> -atanks-5.2.ebuild,
-files/atanks-5.2-build.patch:
@@ -366,4 +371,3 @@
31 Jul 2003; Michael Sterrett <msterret@gentoo.org> atanks-0.9.8b.ebuild:
initial commit. ebuild submitted by Rob Cakebread via bug 25606 (modified)
-
diff --git a/games-action/atanks/atanks-5.6.ebuild b/games-action/atanks/atanks-5.6.ebuild
new file mode 100644
index 000000000000..3884d5207de8
--- /dev/null
+++ b/games-action/atanks/atanks-5.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-5.6.ebuild,v 1.1 2012/10/22 05:31:13 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro:0[X]"
+
+src_prepare() {
+ find . -type f -name ".directory" -exec rm -vf '{}' +
+}
+
+src_compile() {
+ emake \
+ BINDIR="${GAMES_BINDIR}" \
+ INSTALLDIR="${GAMES_DATADIR}/${PN}" \
+ || die
+}
+
+src_install() {
+ dogamesbin ${PN} || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r button misc missile sound stock tank tankgun text title \
+ unicode.dat *.txt || die
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+