summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-05-10 18:46:38 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-05-10 18:46:38 +0000
commit807a27096504f19e90bcf0cb129141e42b85a73f (patch)
tree0eb82537bd7a542b56dbec6f7c10fe9d9a931446 /games-action
parentVersion bump thanks to Alexey Malakhov <brezerk@gmail.com> (diff)
downloadgentoo-2-807a27096504f19e90bcf0cb129141e42b85a73f.tar.gz
gentoo-2-807a27096504f19e90bcf0cb129141e42b85a73f.tar.bz2
gentoo-2-807a27096504f19e90bcf0cb129141e42b85a73f.zip
remove bundled-glew useflag since 1.6 is gone wrt #469284
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/super-hexagon/ChangeLog6
-rw-r--r--games-action/super-hexagon/metadata.xml3
-rw-r--r--games-action/super-hexagon/super-hexagon-15.ebuild15
3 files changed, 13 insertions, 11 deletions
diff --git a/games-action/super-hexagon/ChangeLog b/games-action/super-hexagon/ChangeLog
index 301e0564fa2b..28a03dc162cc 100644
--- a/games-action/super-hexagon/ChangeLog
+++ b/games-action/super-hexagon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/super-hexagon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.3 2013/05/09 14:12:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.4 2013/05/10 18:46:38 hasufell Exp $
+
+ 10 May 2013; Julian Ospald <hasufell@gentoo.org> super-hexagon-15.ebuild,
+ metadata.xml:
+ remove bundled-glew useflag since 1.6 is gone wrt #469284
09 May 2013; Julian Ospald <hasufell@gentoo.org> super-hexagon-15.ebuild:
restrict splitdebug
diff --git a/games-action/super-hexagon/metadata.xml b/games-action/super-hexagon/metadata.xml
index d9b2211adcb3..d647e74d87ea 100644
--- a/games-action/super-hexagon/metadata.xml
+++ b/games-action/super-hexagon/metadata.xml
@@ -10,9 +10,6 @@
<flag name='bundled-libs'>
Use the upstream provided bundled libraries.
</flag>
- <flag name='bundled-glew'>
- Use the upstream provided bundled glew.
- </flag>
</use>
</pkgmetadata>
diff --git a/games-action/super-hexagon/super-hexagon-15.ebuild b/games-action/super-hexagon/super-hexagon-15.ebuild
index 2ba8247f4062..5183bb39296d 100644
--- a/games-action/super-hexagon/super-hexagon-15.ebuild
+++ b/games-action/super-hexagon/super-hexagon-15.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.4 2013/05/09 14:12:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.5 2013/05/10 18:46:38 hasufell Exp $
+
+# we use bundled glew, cause slotting 1.6 does not give us
+# much benefit for one consumer
EAPI=5
@@ -13,7 +16,7 @@ SRC_URI="${PN}-linux-${PV}-bin"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="bundled-libs +bundled-glew"
+IUSE="bundled-libs"
RESTRICT="bindist fetch splitdebug"
MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
@@ -38,8 +41,7 @@ RDEPEND="
media-libs/libogg
media-libs/libvorbis
media-libs/openal
- )
- !bundled-glew? ( ~media-libs/glew-1.6.0 )"
+ )"
S=${WORKDIR}/data
@@ -61,9 +63,8 @@ src_prepare() {
if ! use bundled-libs ; then
einfo "removing bundled-libs..."
cd $(usex amd64 "x86_64" "x86") || die
- rm libglut.so* libogg.so* libopenal.so* libstdc++.so*\
- libvorbis.so* libvorbisfile.so* \
- $(usex bundled-glew "" "libGLEW.so.1.6") || die
+ rm libglut.so* libogg.so* libopenal.so* libstdc++.so* \
+ libvorbis.so* libvorbisfile.so*
fi
}