summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-23 12:33:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-23 12:33:46 +0000
commitd6d37c393fdf0f201e3ce6bc6b55f99ada69aa75 (patch)
treed1f4cba7413e7c51e375b689e3cb3a6288ab75c9 /games-action
parentInitial revision. Ebuild submitted by Michael C. Ferguson <mcf@augustmail.com... (diff)
downloadgentoo-2-d6d37c393fdf0f201e3ce6bc6b55f99ada69aa75.tar.gz
gentoo-2-d6d37c393fdf0f201e3ce6bc6b55f99ada69aa75.tar.bz2
gentoo-2-d6d37c393fdf0f201e3ce6bc6b55f99ada69aa75.zip
initial commit (bug #42569)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/shootingstar/ChangeLog10
-rw-r--r--games-action/shootingstar/Manifest5
-rw-r--r--games-action/shootingstar/files/digest-shootingstar-1.2.01
-rw-r--r--games-action/shootingstar/metadata.xml9
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild27
5 files changed, 52 insertions, 0 deletions
diff --git a/games-action/shootingstar/ChangeLog b/games-action/shootingstar/ChangeLog
new file mode 100644
index 000000000000..3d61087f5360
--- /dev/null
+++ b/games-action/shootingstar/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/shootingstar
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.1 2004/02/23 12:33:46 mr_bones_ Exp $
+
+*shootingstar-1.2.0 (23 Feb 2004)
+
+ 23 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ shootingstar-1.2.0.ebuild:
+ initial commit; ebuild submitted by Thomas Preissler via bug #42569 (modified)
+
diff --git a/games-action/shootingstar/Manifest b/games-action/shootingstar/Manifest
new file mode 100644
index 000000000000..287164b5b699
--- /dev/null
+++ b/games-action/shootingstar/Manifest
@@ -0,0 +1,5 @@
+MD5 b41bcf7f86079eda293ead21c83e72f9 shootingstar-1.0.0.ebuild 1084
+MD5 39b30be74d76b82af0638c25526c8872 shootingstar-1.2.0.ebuild 533
+MD5 e58e94dea4b0a77fa9989440bdf0ebdd files/digest-shootingstar-1.0.0 148
+MD5 333a34929ed7232c52e8003976476d49 files/home_config.patch 690
+MD5 e213ef0a24782b487d5eabba35b82063 files/digest-shootingstar-1.2.0 71
diff --git a/games-action/shootingstar/files/digest-shootingstar-1.2.0 b/games-action/shootingstar/files/digest-shootingstar-1.2.0
new file mode 100644
index 000000000000..4bb051bdb379
--- /dev/null
+++ b/games-action/shootingstar/files/digest-shootingstar-1.2.0
@@ -0,0 +1 @@
+MD5 6cd6e11ec00be95a0a5b5e4cd3649ace shootingstar-1.2.0.tar.gz 7755911
diff --git a/games-action/shootingstar/metadata.xml b/games-action/shootingstar/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-action/shootingstar/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
new file mode 100644
index 000000000000..bc08b3ef191c
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.1 2004/02/23 12:33:46 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="http://www.2ndpoint.fi/ss"
+SRC_URI="http://www.2ndpoint.fi/ss/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/opengl
+ virtual/glu
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}