summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-15 15:48:45 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-15 15:48:45 +0000
commita45485bb62ac332d8127033450c30d2fb133514c (patch)
treedc05f71ea88b1ee5acd01487abf12b19d59d73e6 /games-arcade/conveysdl
parentx86 stable (diff)
downloadgentoo-2-a45485bb62ac332d8127033450c30d2fb133514c.tar.gz
gentoo-2-a45485bb62ac332d8127033450c30d2fb133514c.tar.bz2
gentoo-2-a45485bb62ac332d8127033450c30d2fb133514c.zip
Install menu entry, bug #159853
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-arcade/conveysdl')
-rw-r--r--games-arcade/conveysdl/ChangeLog7
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3.ebuild32
2 files changed, 22 insertions, 17 deletions
diff --git a/games-arcade/conveysdl/ChangeLog b/games-arcade/conveysdl/ChangeLog
index 02906983b46e..dd1f4744f9cc 100644
--- a/games-arcade/conveysdl/ChangeLog
+++ b/games-arcade/conveysdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/conveysdl
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.4 2006/09/01 22:10:03 tupone Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/ChangeLog,v 1.5 2007/03/15 15:48:45 nyhm Exp $
+
+ 15 Mar 2007; Tristan Heaven <nyhm@gentoo.org> conveysdl-1.3.ebuild:
+ Install menu entry, bug #159853
*conveysdl-1.3 (01 Sep 2006)
diff --git a/games-arcade/conveysdl/conveysdl-1.3.ebuild b/games-arcade/conveysdl/conveysdl-1.3.ebuild
index b0544602757c..456cba98e289 100644
--- a/games-arcade/conveysdl/conveysdl-1.3.ebuild
+++ b/games-arcade/conveysdl/conveysdl-1.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.2 2006/09/02 08:37:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/conveysdl/conveysdl-1.3.ebuild,v 1.3 2007/03/15 15:48:45 nyhm Exp $
-inherit games
+inherit eutils toolchain-funcs games
-DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs, if you miss any you go round again"
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${P/-/.}.tar"
@@ -16,12 +16,11 @@ IUSE=""
DEPEND="media-libs/libsdl
media-libs/sdl-mixer"
-S=${WORKDIR}/${PN}
+S=${WORKDIR}
src_unpack() {
- mkdir "${S}"
- cd "${S}"
unpack ${A}
+ cd "${S}"
# Incomplete readme
sed -i \
@@ -33,21 +32,24 @@ src_unpack() {
-e 's:SDL_Mi:SDL_mi:' \
main.c \
|| die "sed failed"
- mv main.c ${PN}.c || die "mv failed"
}
src_compile() {
- CFLAGS="${CFLAGS} `sdl-config --cflags`"
- CFLAGS="${CFLAGS} -DDATA_PREFIX=\\\"${GAMES_DATADIR}/${PN}/\\\""
- CFLAGS="${CFLAGS} -DENABLE_SOUND"
- emake "${PN}" LDLIBS="-lSDL_mixer `sdl-config --libs`" \
+ emake main \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(sdl-config --cflags) \
+ -DDATA_PREFIX=\\\"${GAMES_DATADIR}/${PN}/\\\" \
+ -DENABLE_SOUND" \
+ LDFLAGS="${LDFLAGS} -lSDL_mixer $(sdl-config --libs)" \
|| die "emake failed"
}
src_install() {
- dogamesbin "${PN}" || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r gfx sounds levels || die "installing data failed"
+ newgamesbin main ${PN} || die "newgamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r gfx sounds levels || die "doins failed"
+ newicon gfx/jblob.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Convey /usr/share/pixmaps/${PN}.bmp
dodoc readme
prepgamesdirs
}