summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-04 22:45:32 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-04 22:45:32 +0000
commit47b1a261937aafbfdeb2e45c8a78033e97beb602 (patch)
tree5047ed193288c00af7fd4cdf462da1f5f09d14cd /games-arcade/late
parentDelete old version. (diff)
downloadgentoo-2-47b1a261937aafbfdeb2e45c8a78033e97beb602.tar.gz
gentoo-2-47b1a261937aafbfdeb2e45c8a78033e97beb602.tar.bz2
gentoo-2-47b1a261937aafbfdeb2e45c8a78033e97beb602.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-arcade/late')
-rw-r--r--games-arcade/late/ChangeLog6
-rw-r--r--games-arcade/late/files/late-0.1.0-gcc43.patch11
-rw-r--r--games-arcade/late/late-0.1.0.ebuild6
3 files changed, 20 insertions, 3 deletions
diff --git a/games-arcade/late/ChangeLog b/games-arcade/late/ChangeLog
index 5b1b86150c0c..43afebf61ce3 100644
--- a/games-arcade/late/ChangeLog
+++ b/games-arcade/late/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/late
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/late/ChangeLog,v 1.9 2008/03/25 14:38:55 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/late/ChangeLog,v 1.10 2008/05/04 22:45:31 nyhm Exp $
+
+ 04 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/late-0.1.0-gcc43.patch, late-0.1.0.ebuild:
+ Fix building with gcc-4.3
25 Mar 2008; Santiago M. Mola <coldwind@gentoo.org> late-0.1.0.ebuild:
amd64 stable
diff --git a/games-arcade/late/files/late-0.1.0-gcc43.patch b/games-arcade/late/files/late-0.1.0-gcc43.patch
new file mode 100644
index 000000000000..bce26464cf04
--- /dev/null
+++ b/games-arcade/late/files/late-0.1.0-gcc43.patch
@@ -0,0 +1,11 @@
+--- src/init.cpp
++++ src/init.cpp
+@@ -26,6 +26,8 @@
+ #include "scorescreen.h"
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
++#include <cstring>
+ using namespace std;
+
+
diff --git a/games-arcade/late/late-0.1.0.ebuild b/games-arcade/late/late-0.1.0.ebuild
index 86e6f4a3e80e..112c8dd3b384 100644
--- a/games-arcade/late/late-0.1.0.ebuild
+++ b/games-arcade/late/late-0.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/late/late-0.1.0.ebuild,v 1.13 2008/03/25 14:38:55 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/late/late-0.1.0.ebuild,v 1.14 2008/05/04 22:45:31 nyhm Exp $
inherit eutils games
@@ -18,9 +18,11 @@ DEPEND="media-libs/libsdl
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "/chown/d" \
- "${S}"/Makefile.in \
+ Makefile.in \
|| die "sed failed"
}