summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-10 10:57:08 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-10 10:57:08 +0000
commit46a1727868792e441f5fa91ff096fc9eb7aa37b4 (patch)
treeddb23e8907d9c4bcecdad1d9b118684f7df3a65f /games-arcade/moagg
parentRe-added accidentally removed stable version. (diff)
downloadgentoo-2-46a1727868792e441f5fa91ff096fc9eb7aa37b4.tar.gz
gentoo-2-46a1727868792e441f5fa91ff096fc9eb7aa37b4.tar.bz2
gentoo-2-46a1727868792e441f5fa91ff096fc9eb7aa37b4.zip
Add fix from Debian for building with gcc-4.3 #218833 by Peter Alfredsen.
(Portage version: 2.2_pre5)
Diffstat (limited to 'games-arcade/moagg')
-rw-r--r--games-arcade/moagg/ChangeLog8
-rw-r--r--games-arcade/moagg/files/moagg-0.18-gcc43.patch70
-rw-r--r--games-arcade/moagg/moagg-0.18.ebuild5
3 files changed, 79 insertions, 4 deletions
diff --git a/games-arcade/moagg/ChangeLog b/games-arcade/moagg/ChangeLog
index f75f61565374..4670d801edad 100644
--- a/games-arcade/moagg/ChangeLog
+++ b/games-arcade/moagg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/moagg
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/moagg/ChangeLog,v 1.16 2007/07/02 19:23:28 nyhm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/moagg/ChangeLog,v 1.17 2008/05/10 10:57:08 vapier Exp $
+
+ 10 May 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/moagg-0.18-gcc43.patch, moagg-0.18.ebuild:
+ Add fix from Debian for building with gcc-4.3 #218833 by Peter Alfredsen.
02 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+files/moagg-0.18-gcc42.patch, moagg-0.18.ebuild:
diff --git a/games-arcade/moagg/files/moagg-0.18-gcc43.patch b/games-arcade/moagg/files/moagg-0.18-gcc43.patch
new file mode 100644
index 000000000000..3ac983fa3ef2
--- /dev/null
+++ b/games-arcade/moagg/files/moagg-0.18-gcc43.patch
@@ -0,0 +1,70 @@
+http://bugs.gentoo.org/220193
+
+--- libMoaggCore/src/LevelReader.cpp
++++ libMoaggCore/src/LevelReader.cpp
+@@ -1,4 +1,5 @@
+ #include <sstream>
++#include <cstring>
+
+ #include "Exception.h"
+ #include "Configuration.h"
+--- libMoaggCore/src/System.cpp
++++ libMoaggCore/src/System.cpp
+@@ -4,6 +4,7 @@
+ #include <cerrno>
+ #include <sstream>
+ #include <list>
++#include <cstring>
+
+ #include "Tools.h"
+ #include "SyscallException.h"
+--- libMoaggCore/src/Tools.cpp
++++ libMoaggCore/src/Tools.cpp
+@@ -2,6 +2,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <set>
++#include <cstdlib>
+
+ #include "Exception.h"
+ #include "Tools.h"
+--- libMoaggGame/src/Tiles.cpp
++++ libMoaggGame/src/Tiles.cpp
+@@ -2,6 +2,7 @@
+ #include <cassert>
+ #include <sstream>
+ #include <iomanip>
++#include <memory>
+
+
+ #include "Configuration.h"
+--- testsuite/MyAssertionTraits.h
++++ testsuite/MyAssertionTraits.h
+@@ -2,6 +2,7 @@
+ #define MYASSERTIONTRAITS_H
+
+ #include <cppunit/TestAssert.h>
++#include <cstring>
+
+ CPPUNIT_NS_BEGIN
+
+--- tools/convertmap.cpp
++++ tools/convertmap.cpp
+@@ -3,6 +3,7 @@
+ #include <memory>
+ #include <list>
+ #include <cassert>
++#include <cstdlib>
+
+ #include "Matrix.h"
+ #include "File.h"
+--- tools/modifymap.cpp
++++ tools/modifymap.cpp
+@@ -2,6 +2,7 @@
+ #include <iostream>
+ #include <memory>
+ #include <list>
++#include <cstdlib>
+
+ #include "Matrix.h"
+ #include "File.h"
diff --git a/games-arcade/moagg/moagg-0.18.ebuild b/games-arcade/moagg/moagg-0.18.ebuild
index a61bca5e5286..1efa9d528471 100644
--- a/games-arcade/moagg/moagg-0.18.ebuild
+++ b/games-arcade/moagg/moagg-0.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/moagg/moagg-0.18.ebuild,v 1.3 2007/07/02 19:23:28 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/moagg/moagg-0.18.ebuild,v 1.4 2008/05/10 10:57:08 vapier Exp $
inherit eutils games
@@ -26,6 +26,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc42.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
# We don't want the docs inside ${GAMES_DATADIR}/doc, so we don't
# let "make install" do the doc install.
sed -i \