summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-06 16:41:53 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-06 16:41:53 +0000
commit8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7 (patch)
tree760188d48002d50c5a5dc10ce9107b464676a647 /games-arcade/retrobattle/retrobattle-1.0.0.ebuild
parentVersion bump. Update udev firmware search path and add /lib support patch. (diff)
downloadgentoo-2-8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7.tar.gz
gentoo-2-8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7.tar.bz2
gentoo-2-8fb465cafb6b6fd00baae66f8251fcf8c0aec0e7.zip
initial commit based on ebuild from Alexander Berntsen
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/retrobattle/retrobattle-1.0.0.ebuild')
-rw-r--r--games-arcade/retrobattle/retrobattle-1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
new file mode 100644
index 000000000000..bf1190743706
--- /dev/null
+++ b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/retrobattle/retrobattle-1.0.0.ebuild,v 1.1 2012/08/06 16:41:53 hasufell Exp $
+
+EAPI=3
+inherit eutils games
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="A NES-like platform arcade game"
+HOMEPAGE="http://remar.se/andreas/retrobattle/"
+SRC_URI="http://remar.se/andreas/retrobattle/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# test is incomplete
+RESTRICT="test"
+
+DEPEND="media-libs/libsdl[X,audio,video]
+ media-libs/sdl-mixer[wav]"
+
+S=${WORKDIR}/${MY_P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{build,sound}.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/${MY_P}/data || die
+
+ # wrapper to pass datadir location
+ newgamesbin "${WORKDIR}"/${MY_P}/${PN} ${PN}.bin || die
+ games_make_wrapper ${PN} "${PN}.bin \"${GAMES_DATADIR}/${PN}\""
+
+ make_desktop_entry ${PN}
+ dodoc "${WORKDIR}"/${MY_P}/{manual.txt,README}
+
+ prepgamesdirs
+}