summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-04-15 10:33:33 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-04-15 10:33:33 +0000
commit2ff21fe634c828192f2a68c8b165c779b48e5be3 (patch)
tree6437ce126a1bb3503d9a14b8035d9b7b68b1edd0 /games-arcade/sable/sable-1.0.ebuild
parentinital import. bug #173390 (diff)
downloadgentoo-2-2ff21fe634c828192f2a68c8b165c779b48e5be3.tar.gz
gentoo-2-2ff21fe634c828192f2a68c8b165c779b48e5be3.tar.bz2
gentoo-2-2ff21fe634c828192f2a68c8b165c779b48e5be3.zip
New package. Request bug #126503 by Cristiano Chiucchiolo
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-arcade/sable/sable-1.0.ebuild')
-rw-r--r--games-arcade/sable/sable-1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/sable/sable-1.0.ebuild b/games-arcade/sable/sable-1.0.ebuild
new file mode 100644
index 000000000000..28dbb96e5a6d
--- /dev/null
+++ b/games-arcade/sable/sable-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sable/sable-1.0.ebuild,v 1.1 2007/04/15 10:33:33 tupone Exp $
+
+inherit games
+
+DESCRIPTION="A frantic 3d space shooter."
+HOMEPAGE="http://www.stanford.edu/~mcmartin/sable/"
+SRC_URI="http://www.stanford.edu/~mcmartin/${PN}/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake INSTALL_RESDIR=${GAMES_DATADIR} || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "Install binary failed"
+ insinto "$GAMES_DATADIR/${PN}"
+ doins -r models sfx textures || die "Install data files failes"
+ dodoc README || die "Install doc failed"
+
+ doicon ${FILESDIR}/${PN}.png
+ make_desktop_entry "${PN}" ${PN}
+
+ prepgamesdirs
+}