summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-24 06:40:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-24 06:40:08 +0000
commit89d77da806f3f32916325c2e6865906c7ccefc6d (patch)
treee75b80d8c4d1b9c0b1991a5e03ce18b9081a00d5 /games-arcade/smclone/smclone-0.97.ebuild
parentrevision bump. Make sure we're using the messagebus user as well. (diff)
downloadgentoo-2-89d77da806f3f32916325c2e6865906c7ccefc6d.tar.gz
gentoo-2-89d77da806f3f32916325c2e6865906c7ccefc6d.tar.bz2
gentoo-2-89d77da806f3f32916325c2e6865906c7ccefc6d.zip
version bump - patches and ebuild from Bernard Cafarelli via bug #100608
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-arcade/smclone/smclone-0.97.ebuild')
-rw-r--r--games-arcade/smclone/smclone-0.97.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/smclone/smclone-0.97.ebuild b/games-arcade/smclone/smclone-0.97.ebuild
new file mode 100644
index 000000000000..28f6d9cff5ea
--- /dev/null
+++ b/games-arcade/smclone/smclone-0.97.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/smclone-0.97.ebuild,v 1.1 2005/08/24 06:40:08 mr_bones_ Exp $
+
+inherit eutils games
+
+MUSIC_V=2.0_RC_1
+DESCRIPTION="clone of Super Mario World"
+HOMEPAGE="http://smclone.sourceforge.net/"
+SRC_URI="mirror://sourceforge/smclone/SMC_${PV}_source.zip
+ mirror://sourceforge/smclone/SMC_${PV}_game.zip
+ mirror://sourceforge/smclone/music_${MUSIC_V}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-gfx"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-apps/portage-2.0.51"
+
+S="${WORKDIR}/${PVR}"
+
+src_unpack() {
+ unpack SMC_${PV}_source.zip SMC_${PV}_game.zip
+ cd "${S}"
+ unpack music_${MUSIC_V}.zip
+
+ find . '(' -name '*.dll' -o -name '*.exe' ')' -exec rm {} \;
+ edos2unix Makefile.am autogen.sh configure.ac src/preferences.cpp src/savegame.cpp
+ chmod a+x autogen.sh
+ epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:g" \
+ configure.ac src/preferences.cpp
+
+ #Bump VERSION to the correct one for this release
+ sed -i \
+ -e "s/VERSION=0.96/VERSION=0.97/" \
+ configure.ac \
+ || die "sed failed"
+ ./autogen.sh || die "autogen failed"
+ chmod a+x configure
+ cd src
+ epatch "${FILESDIR}"/${P}-use-HOME.patch
+}
+
+src_install() {
+ dogamesbin src/smc || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/* || die "doins"
+ # Clean up data directory
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/{data/,}Makefile*
+ dodoc *.txt ../readme-linux.txt
+ cd ..
+ dohtml *.html *.css
+ prepgamesdirs
+}