summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-06-01 20:09:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-06-01 20:09:08 +0000
commit9dabc535811e792ea2b68170f535b3435b0cb484 (patch)
tree585f008dad0c911678993bf1019e25c9468794ac /games-arcade/stepmania
parentUpdate to new release. (diff)
downloadgentoo-2-9dabc535811e792ea2b68170f535b3435b0cb484.tar.gz
gentoo-2-9dabc535811e792ea2b68170f535b3435b0cb484.tar.bz2
gentoo-2-9dabc535811e792ea2b68170f535b3435b0cb484.zip
Fix ogg support, bug #131418
(Portage version: 2.1_rc3-r1)
Diffstat (limited to 'games-arcade/stepmania')
-rw-r--r--games-arcade/stepmania/ChangeLog6
-rw-r--r--games-arcade/stepmania/files/digest-stepmania-3.9_rc36
-rw-r--r--games-arcade/stepmania/files/stepmania-3.9-vorbis.patch10
-rw-r--r--games-arcade/stepmania/stepmania-3.9.ebuild6
4 files changed, 24 insertions, 4 deletions
diff --git a/games-arcade/stepmania/ChangeLog b/games-arcade/stepmania/ChangeLog
index c318a70020ef..ec9da6d7a3f0 100644
--- a/games-arcade/stepmania/ChangeLog
+++ b/games-arcade/stepmania/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/stepmania
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.9 2006/05/12 20:04:11 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.10 2006/06/01 20:09:07 tupone Exp $
+
+ 01 Jun 2006; <Tupone@gentoo.org> +files/stepmania-3.9-vorbis.patch,
+ stepmania-3.9.ebuild:
+ Fix ogg support, bug #131418 by Nicolas Blanco
12 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> metadata.xml:
Changed maintainer back to games since warpzero is being retired.
diff --git a/games-arcade/stepmania/files/digest-stepmania-3.9_rc3 b/games-arcade/stepmania/files/digest-stepmania-3.9_rc3
index 6f7360a766d7..88f6ecc6e5d9 100644
--- a/games-arcade/stepmania/files/digest-stepmania-3.9_rc3
+++ b/games-arcade/stepmania/files/digest-stepmania-3.9_rc3
@@ -1,2 +1,6 @@
-MD5 0bfda8ed58362575083d6dc9b8a32a96 StepMania-3.9-rc3-src.tar.gz 3035711
MD5 1c1279d20bf7f11f96b0aaa65aaebcce StepMania-3.9-rc3-linux.tar.gz 9515927
+RMD160 ae6cb869d7c8cfa3a240e6adcfd1b61890add589 StepMania-3.9-rc3-linux.tar.gz 9515927
+SHA256 8faf4f1220a6c0797773c50b8c9b3bbd51f99dff691b161dc246a06a4ba5e8b3 StepMania-3.9-rc3-linux.tar.gz 9515927
+MD5 0bfda8ed58362575083d6dc9b8a32a96 StepMania-3.9-rc3-src.tar.gz 3035711
+RMD160 f6bbfd9fd46bf980c59b3fca14289b269b094888 StepMania-3.9-rc3-src.tar.gz 3035711
+SHA256 ead8de29a6970cbf22b41a81801bc2dc20ea12af6be957a3bda18a86e906dd67 StepMania-3.9-rc3-src.tar.gz 3035711
diff --git a/games-arcade/stepmania/files/stepmania-3.9-vorbis.patch b/games-arcade/stepmania/files/stepmania-3.9-vorbis.patch
new file mode 100644
index 000000000000..a149c629925f
--- /dev/null
+++ b/games-arcade/stepmania/files/stepmania-3.9-vorbis.patch
@@ -0,0 +1,10 @@
+--- aclocal.m4.orig 2006-05-05 19:12:10.412237750 -0600
++++ aclocal.m4 2006-05-05 19:12:22.568997500 -0600
+@@ -1,6 +1,6 @@
+ AC_DEFUN(SM_AUDIO, [
+
+-AC_ARG_WITH(vorbis, AC_HELP_STRING([--without-vorbis], [Disable Vorbis support]), with_vorbis=$enableval, with_vorbis=yes)
++AC_ARG_WITH(vorbis, AC_HELP_STRING([--without-vorbis], [Disable Vorbis support]), with_vorbis=$withval, with_vorbis=yes)
+
+ # This is used to force the integer decoder, on systems that prefer it.
+ AC_ARG_WITH(integer-vorbis, AC_HELP_STRING([--with-integer-vorbis], [Integer vorbis decoding only]), with_int_vorbis=$withval, with_int_vorbis=no)
diff --git a/games-arcade/stepmania/stepmania-3.9.ebuild b/games-arcade/stepmania/stepmania-3.9.ebuild
index f846399b0e5f..d77e508912bd 100644
--- a/games-arcade/stepmania/stepmania-3.9.ebuild
+++ b/games-arcade/stepmania/stepmania-3.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.1 2006/04/26 22:42:07 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.2 2006/06/01 20:09:07 tupone Exp $
-inherit eutils games
+inherit eutils autotools games
IUSE="debug gtk jpeg mp3 mpeg vorbis force-oss"
@@ -35,7 +35,9 @@ src_unpack() {
epatch "${FILESDIR}/${P}"-gentoo.patch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-ffmpeg.patch \
+ "${FILESDIR}/${P}"-vorbis.patch \
"${FILESDIR}/${P}"-alsa.patch
+ eautoconf
}
src_compile() {