summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-30 08:20:59 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-30 08:20:59 +0000
commit1053842b4c7053f40fd69b0184bb0cce9aebbafc (patch)
tree2512b28a725aac35ba3bbb626092b1f7413635be /games-arcade/tuxracer-demo
parentAdded metadata.xml, clarified DESCRIPTION (diff)
downloadgentoo-2-1053842b4c7053f40fd69b0184bb0cce9aebbafc.tar.gz
gentoo-2-1053842b4c7053f40fd69b0184bb0cce9aebbafc.tar.bz2
gentoo-2-1053842b4c7053f40fd69b0184bb0cce9aebbafc.zip
initial ebuild
Diffstat (limited to 'games-arcade/tuxracer-demo')
-rw-r--r--games-arcade/tuxracer-demo/ChangeLog8
-rw-r--r--games-arcade/tuxracer-demo/files/digest-tuxracer-demo-1.11
-rw-r--r--games-arcade/tuxracer-demo/metadata.xml13
-rw-r--r--games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild46
4 files changed, 68 insertions, 0 deletions
diff --git a/games-arcade/tuxracer-demo/ChangeLog b/games-arcade/tuxracer-demo/ChangeLog
new file mode 100644
index 000000000000..c5100bd25442
--- /dev/null
+++ b/games-arcade/tuxracer-demo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-arcade/tuxracer-demo
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxracer-demo/ChangeLog,v 1.1 2003/10/30 08:20:59 vapier Exp $
+
+*tuxracer-demo-1.1 (30 Oct 2003)
+
+ 30 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-arcade/tuxracer-demo/files/digest-tuxracer-demo-1.1 b/games-arcade/tuxracer-demo/files/digest-tuxracer-demo-1.1
new file mode 100644
index 000000000000..8df907bf3762
--- /dev/null
+++ b/games-arcade/tuxracer-demo/files/digest-tuxracer-demo-1.1
@@ -0,0 +1 @@
+MD5 6655c9e46f025c6613daa6c7ff9d7d7f tuxracer-demo-1.1-linux-i386.sh 25704827
diff --git a/games-arcade/tuxracer-demo/metadata.xml b/games-arcade/tuxracer-demo/metadata.xml
new file mode 100644
index 000000000000..5016068c116b
--- /dev/null
+++ b/games-arcade/tuxracer-demo/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+In Tux Racer, players race as one of four arctic characters (including the popular
+Linux® Mascot, Tux the Penguin) through eighteen thrilling downhill courses, while
+collecting herring and performing tricks along the way. Enter cups and compete to win
+the title! Tux Racer includes a variety of options for gameplay, including the
+ability to race courses for time, against computer opponents and even your friends in
+fog, snow, and high winds.
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild b/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild
new file mode 100644
index 000000000000..5ee15e0ea767
--- /dev/null
+++ b/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxracer-demo/tuxracer-demo-1.1.ebuild,v 1.1 2003/10/30 08:20:59 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="race downhill as different artic characters (including Tux!)"
+HOMEPAGE="http://www.tuxracer.com/"
+SRC_URI="tuxracer-demo-${PV}-linux-i386.sh"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+RESTRICT="nofetch"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ virtual/x11"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit http://www.tuxracer.com/?page=downloads.php"
+ einfo "and download ${A}"
+ einfo "and put the files in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself tuxracer-demo-${PV}-linux-i386.sh
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+
+ exeinto ${dir}
+ doexe bin/x86/glibc-2.1/*
+ insinto ${dir}
+ doins EULA GPL LGPL README Tcl_license language *.tcl
+ cp -r characters courses fonts models music tcllib textures ${D}/${dir}
+
+ dodir ${GAMES_BINDIR}
+ dosym ${dir}/tuxracer-demo ${GAMES_BINDIR}/tuxracer-demo
+
+ prepgamesdirs
+}