summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-21 19:49:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-21 19:49:43 +0000
commit28f0d603743b6a0936eed0a73b715e1dbec0799b (patch)
treeca02403e038c9755deca889ba1d53b563025416a /games-arcade/viruskiller
parentVersion bumped. This closes bug #93264. (diff)
downloadgentoo-2-28f0d603743b6a0936eed0a73b715e1dbec0799b.tar.gz
gentoo-2-28f0d603743b6a0936eed0a73b715e1dbec0799b.tar.bz2
gentoo-2-28f0d603743b6a0936eed0a73b715e1dbec0799b.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-arcade/viruskiller')
-rw-r--r--games-arcade/viruskiller/ChangeLog10
-rw-r--r--games-arcade/viruskiller/Manifest6
-rw-r--r--games-arcade/viruskiller/files/digest-viruskiller-1.01
-rw-r--r--games-arcade/viruskiller/viruskiller-1.0.ebuild47
4 files changed, 60 insertions, 4 deletions
diff --git a/games-arcade/viruskiller/ChangeLog b/games-arcade/viruskiller/ChangeLog
index 2f5bad56568f..a2e006030751 100644
--- a/games-arcade/viruskiller/ChangeLog
+++ b/games-arcade/viruskiller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/viruskiller
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.8 2004/12/28 11:51:59 josejx Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.9 2005/05/21 19:49:43 mr_bones_ Exp $
+
+*viruskiller-1.0 (21 May 2005)
+
+ 21 May 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +viruskiller-1.0.ebuild:
+ version bump
28 Dec 2004; Joseph Jezak <josejx@gentoo.org> viruskiller-0.9.ebuild:
Marked ppc stable.
diff --git a/games-arcade/viruskiller/Manifest b/games-arcade/viruskiller/Manifest
index 61c7dfa99616..5f00fe4623c6 100644
--- a/games-arcade/viruskiller/Manifest
+++ b/games-arcade/viruskiller/Manifest
@@ -1,4 +1,6 @@
-MD5 4d5ac2e420b8ed46eb5ac9607e5eacfc ChangeLog 1220
+MD5 3264de53e691dfba4bdc5495b9e90926 viruskiller-1.0.ebuild 1448
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 3264de53e691dfba4bdc5495b9e90926 viruskiller-0.9.ebuild 1448
+MD5 55624b3e878148f378ed63ab18bfeb23 viruskiller-0.9.ebuild 1357
+MD5 4d5ac2e420b8ed46eb5ac9607e5eacfc ChangeLog 1220
+MD5 c828fb45b80d61372ef175e74b1157f6 files/digest-viruskiller-1.0 70
MD5 7aed6b4a5ef035f812b711d9b650f0e0 files/digest-viruskiller-0.9 70
diff --git a/games-arcade/viruskiller/files/digest-viruskiller-1.0 b/games-arcade/viruskiller/files/digest-viruskiller-1.0
new file mode 100644
index 000000000000..93e98863db35
--- /dev/null
+++ b/games-arcade/viruskiller/files/digest-viruskiller-1.0
@@ -0,0 +1 @@
+MD5 de7c78b3abdb4ff488943d78a94f5bb1 viruskiller-1.0-1.tar.gz 4402168
diff --git a/games-arcade/viruskiller/viruskiller-1.0.ebuild b/games-arcade/viruskiller/viruskiller-1.0.ebuild
new file mode 100644
index 000000000000..13aae0588b83
--- /dev/null
+++ b/games-arcade/viruskiller/viruskiller-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-1.0.ebuild,v 1.1 2005/05/21 19:49:43 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Simple arcade game, shoot'em up style, where you must defend your file system from invading viruses"
+HOMEPAGE="http://www.parallelrealities.co.uk/virusKiller.php"
+# download page has a lame PHP thing.
+SRC_URI="mirror://gentoo/${P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^ICONDIR = /s:icons:pixmaps:" \
+ -e "/^BINDIR = /s:/$:/bin/:" \
+ -e "/^DOCDIR = /s:doc/.*:doc/${PF}/html/:" \
+ -e "/^\(KDE\|GNOME\) = /s:=.*:= \$(DESTDIR)/usr/share/applications:" \
+ makefile \
+ || die "sed failed"
+ rm -f doc/LICENSE
+ mv doc/README "${S}"
+}
+
+src_compile() {
+ append-flags -fsigned-char
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+ prepgamesdirs
+}