summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-05-22 12:37:02 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-05-22 12:37:02 +0000
commitf42d54494cd0b84c064fac6c0886e5e32cd74729 (patch)
tree27a3b7169ef8000132d6d78be7108da27b3016c5 /games-arcade/vor/vor-0.5.3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f42d54494cd0b84c064fac6c0886e5e32cd74729.tar.gz
gentoo-2-f42d54494cd0b84c064fac6c0886e5e32cd74729.tar.bz2
gentoo-2-f42d54494cd0b84c064fac6c0886e5e32cd74729.zip
Initial commit, bug #128384
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-arcade/vor/vor-0.5.3.ebuild')
-rw-r--r--games-arcade/vor/vor-0.5.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-arcade/vor/vor-0.5.3.ebuild b/games-arcade/vor/vor-0.5.3.ebuild
new file mode 100644
index 000000000000..f6eb14350308
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/vor/vor-0.5.3.ebuild,v 1.1 2007/05/22 12:37:02 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="http://jasonwoof.org/vor"
+SRC_URI="http://qualdan.com/vor/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ DATA_PREFIX="${GAMES_DATADIR}"/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
+ newicon data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+ dodoc README todo
+ prepgamesdirs
+}